Who can fix the content at the miror servers? Unable dowload FreePBX gzip package

Hi all,

Unable to download FreePBX installation package.
For download I’m using wget folowed by freePBX 14 manual installation instruction for centos 7 on pbxwiki

Download process begins normally

Saving to: ‘freepbx-14.0-latest.tgz’

31% [================================> ] 4,664,880 506KB/s eta 21s

But after some time download speed becomes very low:

Saving to: ‘freepbx-14.0-latest.tgz’

36% [=====================================> ] 5,417,280 1014B/s eta 77s

I try to download it via different ISP link - (at my workspace and home), but same results.
Maybe wrong content on mirror?

have you tried:

Thanks for reply,

Same issue.

Download speed becomes very low after few seconds, see below images.

Maybe there is a firewall or WAF, which is limiting download speed for some countries?

No any more ideas?

Here is an error during update via web (uncomplete download):


why so this: sha1 do not match?

Dear James,

This is incomplete download. As I told in the first post, download process bigins normally, but after downloading 35-40% of package, donload speed becomes 1kB/sec. I do not use any filtering software yet.
So maybe mirror server has speed limit for some contries or ip ranges? I can not find any other reason.

My ip range is

Your connection seems flaky; don’t blame the source servers. Perhaps you’ll have better results connecting through a VPN. Or, download the files to a cloud server somewhere and then copy them to your system.

I pinged your network from various places and was surprised by the slow responses. From Paris, ping time was ~180 to 260 ms; traceroute showed routing via Moscow with ~54 ms. More than 130 ms from Moscow to Tbilisi is slower than I’d expect. Also tried from Pacific side but even slower. Pinging resulted in two replies for every ICMP request. If your data packets are also duplicated, that might explain your trouble.

There is nothing wrong with the mirrors as I was able to download to various places with no trouble. This is to my cheap €10/mo. home service in Paris:

$ wget http://mirror.freepbx.org/modules/packages/freepbx/freepbx-14.0-latest.tgz                                        --2018-06-25 20:46:06--  http://mirror.freepbx.org/modules/packages/freepbx/freepbx-14.0-latest.tgz
Resolving mirror.freepbx.org (mirror.freepbx.org)...
Connecting to mirror.freepbx.org (mirror.freepbx.org)||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 14778587 (14M) [application/octet-stream]
Saving to: `freepbx-14.0-latest.tgz'


14,778,587 4.23M/s in 3.9s

2018-06-25 20:46:10 (3.57 MB/s) - `freepbx-14.0-latest.tgz' saved [14778587/14778587]

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.