Where to edit for to be able to make outgoing calls

hi all, please help with understanding:

there is sip trunk and outbound route. but calling out from extensions are not being performed.
here is sip.conf:

[110]
deny=0.0.0.0/0.0.0.0
secret=password
dtmfmode=rfc2833
canreinvite=no
context=from-internal
host=dynamic
trustrpid=yes
sendrpid=no
type=friend
nat=no
port=5060
qualify=yes
qualifyfreq=60
transport=udp
encryption=no
callgroup=
pickupgroup=
dial=SIP/110
[email protected]
permit=0.0.0.0/0.0.0.0
callerid=110 <110>
callcounter=yes
faxdetect=no
cc_monitor_policy=generic

[120]
deny=0.0.0.0/0.0.0.0
secret=password
dtmfmode=rfc2833
canreinvite=no
context=from-internal
host=dynamic
trustrpid=yes
sendrpid=no
disallow=all
host=172.17.221.117
type=user
dtmfmode=inband
allow=alaw
context=from-pstn

[999]
deny=0.0.0.0/0.0.0.0
secret=password
dtmfmode=rfc2833
canreinvite=no
context=from-internal
host=dynamic
trustrpid=yes
sendrpid=no
type=friend
nat=no
port=5060
qualify=yes
qualifyfreq=60
transport=udp
encryption=no
callgroup=
pickupgroup=
dial=SIP/[email protected]
[email protected]
permit=0.0.0.0/0.0.0.0
callerid=out <999>
callcounter=yes
faxdetect=no
cc_monitor_policy=generic

[sip-in]
disallow=all
host=ip address of VSP
type=peer
dtmfmode=inband
allow=alaw
context=from-trunk-sip-sip-in

here is verbose output:

– Executing [[email protected]:1] Dial(“SIP/110-000001ac”, “SIP/[email protected]”) in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called SIP/[email protected]
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [[email protected]:2] NoCDR(“SIP/110-000001ac”, “”) in new stack
– Executing [[email protected]:3] Progress(“SIP/110-000001ac”, “”) in new stack
– Executing [[email protected]:4] Wait(“SIP/110-000001ac”, “1”) in new stack
– Executing [[email protected]:5] Progress(“SIP/110-000001ac”, “”) in new stack
– Executing [[email protected]:6] Playback(“SIP/110-000001ac”, “silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack
– <SIP/110-000001ac> Playing ‘silence/1.ulaw’ (language ‘en’)
– <SIP/110-000001ac> Playing ‘cannot-complete-as-dialed.slin’ (language ‘en’)
– <SIP/110-000001ac> Playing ‘check-number-dial-again.slin’ (language ‘en’)
– Executing [[email protected]:7] Wait(“SIP/110-000001ac”, “1”) in new stack
– Executing [[email protected]:8] Congestion(“SIP/110-000001ac”, “20”) in new stack
== Spawn extension (from-internal, 998908087339, 8) exited non-zero on ‘SIP/110-000001ac’
– Executing [[email protected]:1] Hangup(“SIP/110-000001ac”, “”) in new stack
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/110-000001ac’

Why are there custom changes in sip.conf. You should never modify that file.

Many providers have one trunk definition for Inbound and one for Outbound - It looks like from above that you are trying to go out through the in door? Or is this just a naming anomaly?

Greg

i could find the way to make in/out calls simultaneously through one SIP trunk.
now , i have another task-to force my custom CID to the outgoing calls.
how to do this,

Assuming there is no restriction on it, pass whatever CallerID you want by setting it on the individual extensions, or re-write it through DialPlan since it seems like you are not using FreePBX to make calls - if your provider won’t allow it, you are out of luck.

Greg