Where is the pjSip from header set?

freepbx
Tags: #<Tag:0x00007f702a623648>

(Jbresee) #1

Hi!
Flowroute is my provider.
All my outgoing calls are set to “private number”. Flowroute support notes that I am sending an invalid pjSIP header field. They see the From field containing the internal IP address of the freepbx server.

I can’t see where I have set this.
Any thoughts on how I might have screwed this up?

Thanks!
Jim


#2

In the Trunk, set From Domain to
sip.flowroute.com
Make sure that the outbound caller ID begins with the country code (+ is optional).
If you still have trouble, at the Asterisk command prompt type
pjsip set logger on
make a test call and confirm the contents of the From header.


(Jbresee) #3

Trunk settings changed, although I used the regional flowroute pop address in the from domain. Was that wrong?

I set the pjsip logger on, and I see the from field still contains the internal IP of the server.
I tried to cut and paste the log, but the board says I am too new to post links.

so, I still have something borked.


#4

Replace the last . with %2E for example
pastebin.freepbx%2Eorg/view/ad3bef44
which can still be pasted into a browser and opened.


(Jbresee) #5

Ok - I think I have the 'private number issue addressed. Thanks for your help!!
Jim


#6

Let us know what was wrong; it may help another member.


(Jbresee) #7

The fix was exactly as you suggested - I just plugged it into the wrong field the first try. Update the trunk->pjsip->advanced->From Domain to read sip.flowroute.com.


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.