When sending VM to email, the message ID has my hosts server address instead of mine

I configured my FreePBX box to send via sendgrid. When I do a test email, via command line, it goes through. But when I get a voicemail to email it doesnt. The issue is, is that I am hosting it on vultr.
When I send if via commandline, the message-id, has my real domain in it. But when it goes out via voicemail to email, the message it has

message-id=<[email protected]>

Is there a way to change it so it will have my domain name?

In my postfix/generic.db section I have
@vultr.com [email protected]

I remaped the file and restarted postfix but it doesnt help

Thank you

AFAIK, it needs to be /etc/postfix/generic (not generic.db)

In the main.cf you need to have

smtp_generic_maps = hash:/etc/postfix/generic

And finally run

postmap /etc/postfix/generic
service postfix restart

Or… You may want to specify your from email address in the voicemail settings, which will also solve this issue.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.