What is the clean way to enable webenabled for the Manager (AMI)?


(Wifx) #1

Hello !

Is there a way to enable the webenabled = Yes in the GUI ?

If I enable it in the manager.conf, it working !
If I enable it in the manager_custom.conf it’s NOT working :frowning:

So what is the right way to set this ?


(Lorne Gaetz) #2

All in Settings -> Advanced Settings under the heading “Asterisk Builtin mini-HTTP server”


(Wifx) #3

Unfortunately, it is not working.

I tried to set Enable the mini-HTTP Server to Yes :

pbx-freepbx*CLI> manager show settings

Global Settings:

Manager (AMI): Yes
Web Manager (AMI/HTTP): No
TCP Bindaddress: 0.0.0.0:5038

But Web manager is still OFF.

What’s wrong ?


(Lorne Gaetz) #4

My apologies, reading too quick. You can enable it by directly editing manager.conf. There is no prohibition against editing this file.


(Wifx) #5

Ok ! I do it that way ! Thank you :slight_smile: