What are the modules, which come with a fresh freePBX 15 distro install?


(R. Stindl) #1

I upgraded my freePBX server from 14 to 15. I still see older modules (13 and even 2.11) in the module-admin list. Is there a list somewhere in the www, which tells me what the standard list of modules of a freePBX 15 server is?


(Jared Busch) #2

on the web? not that i know of.

[jbusch@pbx ~]$ sudo fwconsole ma listonline
[sudo] password for jbusch: 
No repos specified, using: [standard,commercial] from last GUI settings

+----------------------+------------+----------------------------------------------+-------------+
| Module               | Version    | Status                                       | License     |
+----------------------+------------+----------------------------------------------+-------------+
| accountcodepreserve  | 13.0.2.2   | Enabled and up to date                       | GPLv2       |
| adv_recovery         |            | Not Installed (Available online: 15.0.21)    | Commercial  |
| amd                  | 15.0.3     | Enabled and up to date                       | GPLv3+      |
| announcement         | 15.0.3.13  | Enabled and up to date                       | GPLv3+      |
| api                  | 15.0.3.12  | Enabled and up to date                       | AGPLv3+     |
| areminder            |            | Not Installed (Available online: 15.0.14.24) | Commercial  |
| arimanager           | 15.0.3.11  | Enabled and up to date                       | GPLv3+      |
| asterisk-cli         | 14.0.3     | Enabled and up to date                       | GPLv3+      |
| asteriskinfo         | 15.0.14    | Enabled and up to date                       | GPLv3+      |
| backup               | 15.0.10.51 | Enabled and up to date                       | GPLv3+      |
| blacklist            | 15.0.2.14  | Enabled and up to date                       | GPLv3+      |
| broadcast            |            | Not Installed (Available online: 15.0.13)    | Commercial  |
| builtin              |            | Enabled; Not available online                |             |
| bulkhandler          | 13.0.23    | Enabled and up to date                       | GPLv3+      |
| calendar             | 15.0.4.21  | Enabled and up to date                       | GPLv3+      |
| callaccounting       |            | Not Installed (Available online: 15.0.24)    | Commercial+ |
| callback             | 15.0.12    | Enabled and up to date                       | GPLv3+      |
| callerid             |            | Not Installed (Available online: 15.0.16)    | Commercial  |
| callforward          | 15.0.14    | Enabled and up to date                       | AGPLv3+     |
| calllimit            |            | Not Installed (Available online: 15.0.5.6)   | Commercial  |
| callrecording        | 15.0.7.18  | Enabled and up to date                       | AGPLv3+     |
| callwaiting          | 15.0.4.4   | Enabled and up to date                       | GPLv3+      |
| cdr                  | 15.0.17.7  | Enabled and up to date                       | GPLv3+      |
| cel                  | 15.0.15.12 | Enabled and up to date                       | GPLv3+      |
| certman              | 15.0.42    | Enabled and up to date                       | AGPLv3+     |
| cidlookup            | 15.0.20    | Enabled and up to date                       | GPLv3+      |
| conferences          | 15.0.7.8   | Enabled and up to date                       | GPLv3+      |
| conferencespro       |            | Not Installed (Available online: 15.0.3.16)  | Commercial  |
| configedit           | 13.0.7.3   | Enabled and up to date                       | AGPLv3+     |
| contactmanager       | 15.0.8.33  | Enabled and up to date                       | GPLv3+      |
| core                 | 15.0.12.66 | Enabled and up to date                       | GPLv3+      |
| cos                  |            | Not Installed (Available online: 15.0.14)    | Commercial  |
| customappsreg        | 15.0.14    | Enabled and up to date                       | GPLv3+      |
| cxpanel              |            | Not Installed (Available online: 15.0.4)     | GPLv3       |
| dahdiconfig          | 15.0.5.7   | Enabled and up to date                       | GPLv3+      |
| dashboard            | 15.0.11    | Enabled and up to date                       | AGPLv3+     |
| daynight             | 15.0.12    | Enabled and up to date                       | GPLv3+      |
| dictate              | 15.0.7     | Enabled and up to date                       | GPLv3+      |
| digium_phones        |            | Not Installed (Available online: 15.0.6)     | GPLv2       |
| digiumaddoninstaller | 13.0.1.1   | Enabled and up to date                       | GPLv2       |
| directory            | 15.0.18    | Enabled and up to date                       | GPLv3+      |
| disa                 | 15.0.4.9   | Enabled and up to date                       | AGPLv3+     |
| donotdisturb         | 15.0.8     | Enabled and up to date                       | GPLv3+      |
| endpoint             |            | Not Installed (Available online: 15.0.39.62) | Commercial  |
| extensionroutes      |            | Not Installed (Available online: 15.0.8)     | Commercial  |
| fax                  | 15.0.21    | Enabled and up to date                       | GPLv3+      |
| faxpro               |            | Not Installed (Available online: 15.0.8.12)  | Commercial  |
| featurecodeadmin     | 13.0.6.11  | Enabled and up to date                       | GPLv3+      |
| filestore            | 15.0.3.14  | Enabled and up to date                       | AGPLv3      |
| findmefollow         | 15.0.26    | Enabled and up to date                       | GPLv3+      |
| firewall             | 15.0.8.14  | Enabled and up to date                       | AGPLv3+     |
| framework            | 15.0.17.34 | Enabled and up to date                       | GPLv2+      |
| fw_langpacks         | 14.0.1     | Enabled and up to date                       | GPLv3+      |
| hotelwakeup          |            | Not Installed (Available online: 15.0.5.5)   | GPLv2       |
| iaxsettings          | 15.0.8     | Enabled and up to date                       | AGPLv3      |
| infoservices         | 15.0.3     | Enabled and up to date                       | GPLv2+      |
| iotserver            |            | Not Installed (Available online: 15.0.2.8)   | Commercial  |
| irc                  | 13.0.1     | Enabled and up to date                       | GPLv3+      |
| ivr                  | 15.0.29    | Enabled and up to date                       | GPLv3+      |
| languages            | 15.0.12    | Enabled and up to date                       | GPLv3+      |
| logfiles             | 15.0.14    | Enabled and up to date                       | GPLv3+      |
| manager              | 15.0.10    | Enabled and up to date                       | GPLv2+      |
| miscapps             | 15.0.10    | Enabled and up to date                       | GPLv3+      |
| miscdests            | 15.0.2.12  | Enabled and up to date                       | GPLv3+      |
| music                | 15.0.22    | Enabled and up to date                       | GPLv3+      |
| oracle_connector     |            | Not Installed (Available online: 15.0.7)     | Commercial  |
| outroutemsg          | 15.0.9     | Enabled and up to date                       | GPLv3+      |
| paging               | 15.0.4.32  | Enabled and up to date                       | GPLv3+      |
| pagingpro            |            | Not Installed (Available online: 15.0.1.21)  | Commercial  |
| parking              | 15.0.15.4  | Enabled and up to date                       | GPLv3+      |
| parkpro              |            | Not Installed (Available online: 15.0.13)    | Commercial  |
| pbdirectory          | 2.11.0.6   | Enabled and up to date                       | GPLv3+      |
| phonebook            | 15.0.12    | Enabled and up to date                       | GPLv3+      |
| pinsets              | 15.0.1.15  | Enabled and up to date                       | GPLv3+      |
| pinsetspro           |            | Not Installed (Available online: 15.0.4)     | Commercial  |
| pm2                  | 15.0.6     | Enabled and up to date                       | AGPLv3+     |
| pms                  |            | Not Installed (Available online: 15.0.2.52)  | Commercial  |
| presencestate        | 15.0.11    | Enabled and up to date                       | GPLv3+      |
| printextensions      | 13.0.3.4   | Enabled and up to date                       | GPLv3+      |
| queueprio            | 15.0.10    | Enabled and up to date                       | GPLv3+      |
| queues               | 15.0.33    | Enabled and up to date                       | GPLv2+      |
| queuestats           |            | Not Installed (Available online: 15.0.3.32)  | Commercial  |
| qxact_reports        |            | Not Installed (Available online: 15.0.3.33)  | Commercial  |
| recording_report     |            | Not Installed (Available online: 15.0.4.33)  | Commercial  |
| recordings           | 15.0.3.15  | Enabled and up to date                       | GPLv3+      |
| restapps             |            | Not Installed (Available online: 15.0.19.37) | Commercial  |
| ringgroups           | 15.0.11.14 | Enabled and up to date                       | GPLv3+      |
| sangomaconnect       |            | Not Installed (Available online: 15.0.21)    | Commercial  |
| sangomacrm           |            | Not Installed (Available online: 15.0.22)    | Commercial  |
| setcid               | 15.0.9     | Enabled and up to date                       | GPLv3+      |
| sipsettings          | 15.0.6.39  | Enabled and up to date                       | AGPLv3+     |
| sipstation           |            | Not Installed (Available online: 15.0.5.20)  | Commercial  |
| sms                  |            | Not Installed (Available online: 15.0.18)    | Commercial  |
| soundlang            | 15.0.5.10  | Enabled and up to date                       | GPLv3+      |
| speeddial            | 2.11.0.4   | Enabled and up to date                       | GPLv3+      |
| superfecta           | 15.0.2.29  | Enabled and up to date                       | GPLv2+      |
| sysadmin             | 15.0.21.55 | Enabled and up to date                       | Commercial  |
| timeconditions       | 15.0.15.10 | Enabled and up to date                       | GPLv3+      |
| tts                  | 15.0.11    | Enabled and up to date                       | GPLv3+      |
| ttsengines           | 15.0.4.7   | Enabled and up to date                       | AGPLv3      |
| ucp                  | 15.0.6.26  | Enabled and up to date                       | AGPLv3+     |
| userman              | 15.0.35    | Enabled and up to date                       | AGPLv3+     |
| vega                 |            | Not Installed (Available online: 15.0.10)    | Commercial+ |
| vmblast              | 15.0.11.6  | Enabled and up to date                       | GPLv3+      |
| vmnotify             |            | Not Installed (Available online: 15.0.12)    | Commercial  |
| voicemail            | 15.0.18.34 | Enabled and up to date                       | GPLv3+      |
| voicemail_report     |            | Not Installed (Available online: 15.0.6)     | Commercial  |
| vqplus               |            | Not Installed (Available online: 15.0.7.21)  | Commercial  |
| weakpasswords        | 13.0.2     | Enabled and up to date                       | GPLv3+      |
| webcallback          |            | Not Installed (Available online: 15.0.6.3)   | Commercial  |
| webrtc               | 15.0.10    | Enabled and up to date                       | GPLv3+      |
| xmpp                 | 15.0.6.9   | Enabled and up to date                       | AGPLv3      |
| zulu                 |            | Not Installed (Available online: 15.0.58.9)  | Commercial  |
+----------------------+------------+----------------------------------------------+-------------+

(Lorne Gaetz) #3

There is no requirement that module version match the framework version. It’s all good.


(R. Stindl) #4

Ok thanks…to both of you! I just wondered if some of those 2.11 versions are even functional or just a left over of the previous freePBX version.


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.