FreePBX | Register | Issues | Wiki | Portal | Support

Weird network Issues NO IP/Unable to activate


#1

Hello!.. I’ve had nothing but issues since a fresh install of the latest disto on a Lenovo Q190. I kept getting boot errors and I eventually changed the BIOS os legacy and I was able to get freepbx to boot up. I cant get centos to get an IP so I went to Ifcnfg-eth0 in terminal and changed onboot from “no” to “yes” rebooted and still had the same issue… So I created a static IP address in that file because I still at this point were unable to access the GUI. I rebooted and now when logging in via root in terminal under eth0 its giving me the static IP I created and also a new mac address under that IP (weird)… anyway the point I am at now Is I am able to log into the GUI but If I try and activate or grab my external IP address in sip settings I keep getting an error… “Unable to resolve”


(Itzik) #2

Seems like a DNS issue, did you troubleshoot that already?


#3

Yes I did. Sorry I should have mentioned that.


#4

If its worth mentioning… I tried to install an older distro and after install I get an error “Some Firstboot error occurred, and the system is not properly set up”. So I reinstalled the latest distro and I’m back at square one with not being able to get an IP address and having to assign a static one via terminal just to access the GUI.


#5

Can you ping 8.8.8.8? If not, confirm that you have the correct entries for NETMASK and GATEWAY in your ifcfg-eth0 file. If that doesn’t help, report whether you can ping the gateway, what kind of router/firewall you have, etc.

If you can ping 8.8.8.8, can you ping google.com? If that won’t resolve, check your /etc/resolv.conf file. If it’s empty, try adding a line
nameserver 8.8.8.8
to that file.

If you can ping google.com but still get Unable to resolve from SIP Settings, use tcpdump to troubleshoot the DNS lookup.


(system) #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.