Weird Forwarding Issue I Can't Figure Out

Hey all! I’m unfortunately inexperienced with FreePBX but I’m hoping someone can help. I tried creating an account on their forums but it refuses to let me log into it now. I work for an MSP that recently took over for a law firm that uses Grandstream GXP2170 phones on top of a FreePBX/Asterix system. The previous IT left us very little documentation and we’re working a bit blind here.

This one’s a weird one. So I’ll break down the scenario here. The phone in question belongs to a Legal Assistant, who works with 3 different lawyers at this firm. Her phone is setup to show their three extensions on soft buttons on the left side of the screen. When they are on the phone or their phones are ringing, the buttons go solid or flashing red respectively to indicate this. What’s also supposed to happen is if the lawyer’s phones ring and they don’t answer after 10 seconds, it’s supposed to start ringing her phone, flashing the respective lawyers line and also showing the call display info of whoever’s calling.

The problem was, around Easter this year (just after we took over here), she says she went to set a voice mail greeting to indicate she’d be away for a few extra days (something that shouldn’t impact this at all) and the forwarding got all screwed up. Here’s what happens now. Instead of ringing the lawyer’s line for 10 seconds before kicking to her, it rings for about 3 seconds. In addition to that, when her phone starts ringing, it acts like she’s getting a direct phone call, so the indicators of which lawyer’s phone is ringing disappear and she can’t tell who the call was for. Weirder still, the call display shows her name and extension in this scenario. So instead of seeing what lawyer’s line is forwarding and who the call is from, the phone is just telling her that she’s receiving a direct call from…herself.

I tried comparing her extension to another similarly configured one that works and everything seems to line up. I asked about the issue on the Grandstream forums and was told to try deleting her extension, factory resetting her phone and effectively, setting the whole thing up from scratch. I did that and the issue persists still.

I’m kind of tearing my hair out at this point. Unfortunately, working rather blind as we are, I’m fumbling around a bit and am out of ideas.

If anyone can help, I’d greatly appreciate it. Thanks!

I don’t think we have enough information to definitively tell you what’s right or wrong. One thing for certain, though, is that you’re bore-sighted on a problem so finding the actual cause will be harder than it needs to be. Here are some new places to look:

  1. The Lawyer’s phones should each be set up the same way as each other. If I was setting the system up, I’d probably use a Find-Me/Follow-Me list to set the assistant to start ringing if the main phone rings for more than a few seconds (10 work for me). Other common ways to do this are using queues and ring-groups, but these just leave me (personally) cold in this simple setup. Use the GUI to look up the Ring Group, Queue, and Find Me settings for the phones and make sure they make sense.

  2. I’m going to guess that she probably forwarded her phone to her phone instead of turning forwarding off when she got back. It’s been months ago, so asking her what she did to make the phone not work is a non-starter. In spite of that, you should be able to skull out what she did.

  3. The system has “step-by-step” reports on what each call does in the file ‘/var/log/asterisk/full’. You can use this to track the progress of the call and see what’s actually happening. Yes, it is hard to read and no, there probably aren’t any easier ways to figure this out. Follow the “big names” (don’t get wrapped up in the minutiae of the log) look for what contexts are working through.

Final Fun Fact: The phone can be set to forward it’s own calls, or you can use Asterisk (and FreePBX) to set up forwarding. I’m going to guess that the phone was set up for forwarding at the phone. Resetting the phone to factory might help, but these phones keep their “local settings” in the TFTP repository, thereby making misconfiguration settings immutable until you actually go into the phone and clear the problem.

I’m sure we can help - just explore a little more and see if you can spot how the “10 second” delay is supposed to be working and work forward from there.

Sounds like she’s enabled Follow Me, honestly. Check that out.

1 Like

Hey guys! I apologise for taking so long to respond. We’ve been understaffed at work and this ticket got sidelined for a while.

So I’m still ripping my hair out over this one. I compared the extension in question to others used by Legal Assistants in FreePBX and I honestly can’t see any difference in settings. I also connected to the phone’s internal setup and can’t find anything related to call forwarding under the Call Features menu.

cynjut, I looked for all the settings you mentioned but Ring Groups here are only used for receptionists and it doesn’t appear Queues are being used at all. The Find Me settings for one of the two lawyers that forward have their extension (as every extension does), then the assistant having the issue. The other lawyer has their extension, then their cell phone, then the legal assistant. The legal assistant just has their own extension in the Follow Me list, as would be normal. Her No Answer settings are Follow Me and Normal Extension Behavior, which every other extension in the office has. Under Follow Me, her extension has Enabled set to No, which most others do as well. Nothing seems off to me.

As for the logs, I haven’t done that analysis yet but I can try through the FreePBX interface. Is there a way I can filter the log to only show activity related to her extension? Just skimming through it, I don’t see anything that references specific extensions.

Thanks so much for your help!

Was an incredibly obscure fix but I had time to dig into the ticket again today. The problem was that under the Advanced options for her extension, one of her internal Caller ID entries wasn’t set correctly. On other extensions, they have their extension number as the Internal DID and their Internal Caller ID is set to blank, which fills in ANY automatically. This extension had those reversed for some reason and this was causing her extension number to show as the caller ID on all internal calls, which made sense as she was getting the Follow Me from the lawyers she works with. After correcting these settings, her extension returned to normal.

I tripped over this setting by pure luck but a win’s a win. :slight_smile: There are few things more satisfying than closing a 74 day old ticket. Thanks everyone!