Weird Caller ID

I am using PBX in a Flash and Caller ID Superfecta. I have had it working before, but something must have changed. When some people call, the caller id shows:

Forward John Smith
For Private

AT&T was my phone service provider and I must keep it for my alarm system. I setup my AT&T number to forward to my CallCentric (PBXiaF) number so I can use my Ciscos.

It only does this when I call my AT&T number (forwarded to CallCentric number).
When I call my CallCentric number direct, it works fine.

My old PBXiaF system didn’t do this… Anyone know how to make it not show “Forward” and “For Private?”

Thank you!

Try disabling Superfecta or set the CallerID source to none in the inbound route.

Sorry to bring back an old post. I still haven’t figured this out. I did like you said and disabled Superfecta. I also set CallerID source to none in the inbound route. The same Forward… For Private.

Thank you for your help!