WebRTC Softphone module now available for FreePBX!

Schmooze Com, Inc. announces first public release of WebRTC Softphone module for FreePBX.

 

Neenah WI, - January 27, 2014 - Today, Schmooze announces the availability of the BETA release of The FreePBX WebRTC Softphone. This is the first public release of an officially supported WebRTC module for the world’s most popular Open Source PBX platform, FreePBX.

 

WebRTC stands for “Web Real-Time Communications,” a technology focused on embedding real-time communications, such as voice, directly within web browsers.

 

The new WebRTC add-on module allows FreePBX users to enable real-time communications from a web browser directly with their FreePBX system. System administrators will enable an additional WebRTC device in their end users User Control Panel, thereby allowing end users to make and take calls directly from a supported web browser. Anytime a user’s regular extension rings, the WebRTC Softphone will also ring if they are logged into the phone, allowing them to take calls directly from a browser.

 

“This Free WebRTC add-on to FreePBX will enable end users of FreePBX to stay in touch, as well as provide exciting new options for contact centers and businesses wanting to utilize FreePBX within their environments.” commented Preston McNair, Vice President, Sales and Marketing at Schmooze Com, Inc./FreePBX. “In my personal testing I have even used it directly with the browser on my Android Tablet; this is just the start of where this technology will eventually take us.”

 

FreePBX system administrators can download the WebRTC module from within the FreePBX Module Admin, or check out this video that shows off some of the new features enabled by the WebRTC module.


For the latest FreePBX news, updates and information follow FreePBX and Schmooze Com, Inc. on Twitter at @freepbx @schmoozecom

 

On Behalf of the Schmooze Com/FreePBX Team,

  

Preston McNair, VP of Sales and Marketing, FreePBX/Schmooze Com Inc 

   

Connect with Us:

 



Copyright © 2013, Schmooze Com Inc FreePBX is a Registered Trademark of Schmooze Com Inc All Rights Reserved.

Does the module support only extensions mode? Also, how do I download and install the module package?

Wow…great job guys.

Bruce… they told you how to install it in the article. If you need support please ask in. The forum.

You can clone http://git.freepbx.org/scm/freepbx/webrtc.git.

But, Does Freepbx 2.11 support this module? My "Module Admin" does not found WebRTC, because no WebRTC source on http://mirror.freepbx.org/modules/

Manual install fail.

You need to have at least Asterisk 11.5, the module won’t show up in Module Admin until next week as we are doing limited structured releases of this module for distros we can control so we don’t have to deal with a large amount of bug requests. It will be released on other systems shortly.

Can you explain what you mean by “Manual Install Fail”

I clone git repo and copy files to webroot directory (/admin/modules/webrtc). Module Admin locate and install WebRTC and it works correctly (echo test works).

What’s the best way to upgrade Asterisk to 11.5 so I can install and try out the WebRTC? I’m currently on 11.4 within my FreePBX distro.

yum update asterisk11

Glad you got it working! Dont worry about the little english bit, just wanted to know what your errors were specifically. But since you got it working nevermind :slight_smile:

Yeah, tried that. I got a weird response.

[[email protected] ~]# yum update asterisk
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
Setting up Update Process
No Match for argument: asterisk
No package asterisk available.
No Packages marked for Update
[[email protected] ~]#

I mean I obviously have asterisk installed. Not sure what I’m missing.

That because you operation system does’t know where locate packages. You must:

  1. go to link http://packages.asterisk.org
  2. select your OS
  3. copy *.repo file with version asterisk 11 to: /etc/apt/sources.list on Debian like OS;
    and /etc/yum.repos.d/ RHEL like OS.
  4. Be sure set enabled=1
  5. yum update asterisk

Thanks I didn’t realize that repo wasn’t already there. Guess I wasn’t paying much attention.

Last issue (hopefully). I’m getting a dependency error it seems.

–> Finished Dependency Resolution
Error: Package: wanpipe-7.0.2-kernel.2.6.32.279.11.1.el6.dahdi.2.6.1.rel.44.x86_64 (@pbx1)
Requires: dahdi-linux = 2.6.1
Removing: dahdi-linux-2.6.1-13_centos6.x86_64 (@anaconda-CentOS-201207061011.x86_64/6.3)
dahdi-linux = 2.6.1-13_centos6
Updated By: dahdi-linux-2.8.0.1-1_centos6.x86_64 (asterisk-current)
dahdi-linux = 2.8.0.1-1_centos6
Available: dahdi-linux-2.6.1-7_centos6.x86_64 (pbx)
dahdi-linux = 2.6.1-7_centos6
Available: dahdi-linux-2.6.2-1_centos6.x86_64 (asterisk-current)
dahdi-linux = 2.6.2-1_centos6
Available: dahdi-linux-2.7.0-1_centos6.x86_64 (asterisk-current)
dahdi-linux = 2.7.0-1_centos6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[[email protected] ~]#

Any ideas?

I think it is a conflict over packages from different repos (pbx and asterisk-current). You can try disable some repos.

This is incorrect. if you are using the FreePBX disto you should never be adding in random remote repos.

the correct command should have been: yum update asterisk11

If you are using the FreePBX distro you should never ever be dealing with remote repos.

yum update asterisk11

I found the upgrade scripts (http://wiki.freepbx.org/display/FD/FreePBX-Distro-5.211.65) and these are exactly what I was missing. I ran these (in order of course) and I’m able to install the WebRTC phone module and use it successfully. I’m still learning FreePBX. Previously my only experience with FreePBX was via Elastix. Thanks guys!

My webRTC with Chrome is working only for outbound calls, inbound calls goes to voice mail. no registration appear in peer status.
I opened my firewall http:tcp 8088 for my PC.
BTW my PBX is on the Cloud in a VPS
Thanks great apps

Do we need to open any port for WebRTC to work as remote extensions? Please specify protocol (TCP/UDP?Both).

The protocol is WS for websockets and the module handles that for you by creating a separate device and linking the device to your main extension