Webrtc on STABLE 10.13.66-64bit no incoming calls accepted


I have a fresh installation based on STABLE 10.13.66-64bit.
All configurations are default except for the IP addresses. My server is not exposed to the public internet hence I have not forwarded any ports on the firewall.
Extensions some are sip but majority on PJSIP, all are working fine except when it comes to UCP /WEBRTC implementation.

I can generate a call from my WEBRTC Phone , no voice issues.
I have tried this using my sip extension as well as my PJSIP extension they both behave the same , generate calls.

When I call the webrtc associated extension the call does not go though, it immediately fails and on the asterisk log I get the following message :: Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)

That is true because the output of my :: sip show peers command clearly displays Unreachable status next to the webrtc extension number
Yet it can generate calls !!

I tried all combinations Enable AVPF , ICE support … none worked for me.

Accessing the ucp interface using https is a no go , the phone sign remains red and the asterisk cli does not even recognize any activity.
Moving back to http the following message appears ::
== WebSocket connection from ‘192.168.xx.xx:53561’ for protocol ‘sip’ accepted using version ‘13’
– Registered SIP ‘997xxx’ at 192.168.xx.xx:53561
[2017- 19:24:42] NOTICE[32201]: chan_sip.c:29976 sip_poke_noanswer: Peer ‘997xxx’ is now UNREACHABLE! Last qualify: 0

My webrtc Phone version ::

By the way I have uninstalled the following (recommended by some users having a similar behavior)

  1. UCP node server
  2. Digium phones config
  3. Conference Pro

Could someone share with me some guideline on how to have the webrtc working ?
Thank you in anticipation for an early reply.

WebRTC works just fine (for me) using both Chrome and Firefox, provided:

  • you use https for browsing to UCP
  • you have a valid tls cert and fqdn to browse to
  • you enable permissions for the browser to display notifications and use microphone
1 Like


you use https for browsing to UCP

When I use HTTPS my phone sign remains red, before I uninstalled UCP node server I was having a red bar on top.

you have a valid tls cert and fqdn to browse to

Valid tls certificate , I can generate one self-signed although the default certificate created during the installation should suffice. As for the FQDN I earlier stated that my pbx is on a private lan not exposed to the internet. What for I need the FQDN in this case ?

you enable permissions for the browser to display notifications and use microphone

That is done already , I can make outgoing calls without any issues.

Could you please post an extract of the extension settings and what type did you use pjsip or sip ?
I forgot to mention that the ISO was shipped by default with ports 5060 for pjsip and 5160 for SIP is that your case too ?

thank you for your help.


I owe you an apology and a big appreciation.
Thank you for pointing me to the right direction.

I had to give an FQDN, defined it on my DNS server as well as created a letsencrypt certificate.
Everything is perfectly working not a single glinch… THANK YOU

1 Like

Correct SSL only works off of FQDN and WebRTC requires SSL