WebRTC not working on UCP

Trying the WebRTC application on UCP.
When I hit the dial button nothing happens. I can however place a call using the originate call field under the settings wheel.

Can you help?

Using default certificates. Tried to create a new one, but get this error:
Error Generating Certificate: Signature ok
subject=/CN=Asterisk Private CA/O=localhost.localdomain
Getting CA Private Key
unable to load CA Private Key
139768771479368:error:06065064:digital envelope routines:EVP_DecryptFinal_ex:bad decrypt:evp_enc.c:596:
139768771479368:error:0906A065:PEM routines:PEM_do_header:bad decrypt:pem_lib.c:483:

Delete your certificates and Certificate Authority and try to set up the certificates again.

Deleted certificates and certificate authority. Then created new certificate authority.
Then new certificate.
Same error:
Error Generating Certificate: Signature ok
Getting CA Private Key
unable to load CA Private Key
140365724067656:error:06065064:digital envelope routines:EVP_DecryptFinal_ex:bad decrypt:evp_enc.c:603:
140365724067656:error:0906A065:PEM routines:PEM_do_header:bad decrypt:pem_lib.c:483:

How are you creating these certificates. There are a few options. I have yet to have an error on my end.

What is your hardware?

2 Dell R430 on FreePBX High Availability. Lots of horsepower.
FreePBX Distro, two weeks old.

I create these certificates via the GUI, just click “Generate A New Certificate”.
That’s it.

Do I have to do anything else?

I got the same thing happening on all of my FreePBX installs. Two freepbx distro HA systems and one PIAF.

I do however see a .key and a .cert file in /etc/asterisk/keys under the name I just used to create the cert in the GUI.
Looks like the files are there, but I can’t select the cert under extensions.

Can you check that all of your modules are up to date, please?

And a screenshot of the error would be extremely helpfull too :sunglasses:

Creating CA:

Create Certificate:


Test123.crt, .csr, .key files are there in /etc/asterisk/keys

Dont use a passphrase. Try it that way

That took care of the error. Certificate created.
Assigned to my UCP extension. Now trying to make a call from UCP using the WebRTC app. I click to dial a number, nothing happens. Other features, such as sending faxes from UCP and placing a call using the originate call field under the settings wheel, work.

We really provide no support for WebRTC. If it works for you great if not… well it’s like shooting fish in a barrel in a dark room.


I get to the point when I’ve created the CA and a certificate. Then I turn DTLS on in my extension, but It register but can not make o receive calls. What’s the next step?