WebPhone call not getting or sending any sound

I am using freePBX on an EC2 Instance. I am using Freepbx 13. I haven’t configured any sip trunking yet. All I am doing is, Created few extensions & configured them on soft phones (3cx, zoiper & xlite). I can make successful calls among the extensions while using the softphones. But when I try to make call from UCP WebPhone, the soft phones are getting the call but with 2 problems:

  1. The call is dropping after 30 sec
  2. No voice is heard from any of the sides.

But that same extension is functional while using the soft phones. I have tried using Firefox, Chrome. I have SSL certificate configured as well.

Can some one please guide me what are check points I need to check inorder to make this webPhone call working. Thanks In advance

Try adding a STUN server for wertc in Settings, Asterisk SIP Settings.

Thanks for Reply, After adding the stun server situation has changed a little bit. Here are my observations:

  1. I have added stun.l.google.com:19302 in the WebRTC Settings STUN server. The call drops after approximately 35-45 sec. Earlier it was 30sec.

  2. I have tried adding stun.l.google.com:19302 in the RTP Settings STUN server. The call keeps going on with out dropping.

But couldn’t hear any sound for both cases mentioned above. 1 thing, If i click hold on Webphone, I can hear the waiting sound on soft phone. But If i click hold on soft phone, I cannot hear any sound on Webphone.

Your have RTP problems on your system. In the Asterisk logs you will see there are RTP issues. This is a NAT/Network issue and has little to do with the webphone itself.

Thanks for the Reply. On the Asterisk log (full) following is what I am getting:

[2017-09-18 06:14:08] WARNING[27249][C-000002c0] res_rtp_asterisk.c: Failed to create ICE session check list: Too many objects of the specified type (PJ_ETOOMANY) (0x7f0878107828)
[2017-09-18 06:14:08] ERROR[27249][C-000002c0] netsock2.c: getaddrinfo(“e5765tgqtl9u.invalid”, “(null)”, …): Name or service not known
[2017-09-18 06:14:08] WARNING[27249][C-000002c0] chan_sip.c: Invalid host name in Contact: (can’t resolve in DNS) : ‘e5765tgqtl9u.invalid’

Any Idea, on how to fix thie error mentioned in the log

There is no way to fix that. Asterisk is going to increase it in a future version but for now there’s nothing you can do