Web Interface is not working [Solved]

After I updated all the modules the FreePBX web manager is not working the right way, now I don’t know how to turn it back as it was:

-Unable to load the menu the proper way
-Unable to click on the menu tabs
-Unable to do a backup file of settings
-Unable to navigate within the settings

I have tried with Firefox and Google Chrome. Same issue

I don’t know if it is a problem with the current web interface module or if a need a full FreePBX Reset and Installation. I am using FreePBX Distro in a Vmware container.

Update: The problem may be solved by running “amportal a r” from the terminal cli.
Solution Powered by GameGamer43 (Developer)

FF, Chrome and IE do not appear to be loading the CSS. The pages function properly, but it’s rather cryptic.

Unable to find: http://pbx/admin/assets/css/mstyle_autogen_1336332250.css?load_version=

After I upgraded to 2.10…3 this morning, I suffered the same problems. When I checked the web server log I found errors like this

File does not exist: /var/www/html/admin/assets/css/mstyle_autogen_1338405657.css

When I checked the directory, I found mstyle_autogen_1356020982.css. I copied that file to the name of the missing file and the problem seems to be fixed

Yep! Updating just the FreePBX Framework broke things and found the same error with mstyle_autogen_1338405657.css does not exist.

Copied the only style sheet in the directory to the missing file name and “fixed” it, but I wonder if there are changes to that missing style sheet and I am worried about what we find later that is not quite right.

I know that Tony or Peter will advise.

Thanks for the heads up!

My motto, never be an early adopter or upgrader!


This can be fixed by doing an amportal a r from the cli. I also checked in a fix earlier this week which should prevent this in the future and will be rolled when we roll a new framework module.

@gamegamer… is the file rename adequate or should we change it back and do the amportal a r ?


The best way to resolve it is to run the amportal a r command if this happens at this time.

I’ve found that if you click the ‘apply changes’ link and then navigate back to the base url it works fine.

@jkillen, just an FYI for others, I tried that first and that did not work for me and I was prepared for this exact failure.

Guess I just got lucky. Still, probably worth a try before jumping through the hoops described here.

I would like to confirm that using “amportal a r” from the terminal fix the issue. Thank you GameGamer43 For the Amazing Support. I hope this problem will be solved in the next module update.

Best Regards,