Web interface error

I have installed freepbx 2.5.1 with asterisk on ubuntu 9.04. I have done the installation (successfully as indicated by the system :/) and when i try to use the web interface i got the following errors

Warning: require_once(DB.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/html/admin/common/db_connect.php on line 14

Fatal error: require_once() [function.require]: Failed opening required ‘DB.php’ (include_path=’.:/asterisk/static/config/index.html’) in /var/www/html/admin/common/db_connect.php on line 14

Any help on that would be really appreciated!

(Btw as a newbie i am i don’t know if you need more info, so if you need just let me know :))

EDIT: also when i go to the Voicemail & Recordings (ARI) i see the following error:
PHP PEAR must be installed. Visit http://pear.php.net for help with installation.

Which is very confusing as i have installed pear :confused:

As you are a newbie i would like to point out that installing FreePBX does not check for all dependancies so care must be taken to do so manually.

Read the following, you may need to adjust the instructions to match your version of ubuntu.


if these instruction have been followed and still there is a problem then I’m sorry I can’t help any further as I am only familiar with the quirks of CentOS.

This is due to missing php-pear-DB package.
Depending on the flavor of Linux that you have, you can install it via the appropriate package manager. Note this problem once occurred when I enabled a third party repository and it contained a package named php-pear-db (note the lower case ‘db’) which was set to supersede php-pear-DB. As a result it removed the files mentioned as missing in you PHP error.

I have no answer and I have the same problem. The difference is that I have all working before it started to work.

I have to believe that somebody access and corrupt the system by a port that I thought the firewall were protecting and it didn’t.

How to check the settings?