Web GUI giving 500 error after most recent updates

Hello

Getting a internal server error after downloading and processing the most recent updates from yesterday. Running RasPBX.

There are 12 modules available for online upgrades
cdr 13.0.29.8 (current: 13.0.29.5)
cel 13.0.25 (current: 13.0.23)
conferences 13.0.22 (current: 13.0.21)
core 13.0.112 (current: 13.0.106)
framework 13.0.181 (current: 13.0.167)
iaxsettings 13.0.5 (current: 13.0.4)
music 13.0.22 (current: 13.0.21)
paging 13.0.24 (current: 13.0.21)
queues 13.0.30 (current: 13.0.27)
soundlang 13.0.17 (current: 13.0.15)
ucp 13.0.41 (current: 13.0.38)
voicemail 13.0.53 (current: 13.0.51)

My apache2 error log shows:

[Wed Sep 07 23:07:16.313906 2016] [core:alert] [pid 1092] [client 192.168.1.30:63292] /var/www/html/admin/.htaccess: Invalid command ‘RewriteEngine’, perhaps misspelled or defined by a module not included in the server configuration

My systemctl shows:

● systemd-modules-load.service loaded failed failed Load Kernel Modules

Any suggestions on getting my web GUI running again?

Tried reloading the framework, rebooted. Try following the other 500 error threads. No dice.

Thanks.

This is a custom install. You need to enable mod_rewrite in apache. It’s now a requirement.

Thanks, that got the web gui working, however now after login to the admin module I am seeing this:

Again. You are on a self-installed system and you have commercial modules but you don’t have zend guard. You need to remove all commercial modules if you don’t have zend guard installed, which you don’t.

Looks to be a raspbx. I am not sure how you even got sysadmin installed.

Thanks tm1000

Used the following commands to enable mod_rewrite and then to remove sysadmin and everything is working again

a2enmod rewrite

service apache2 restart

then

amportal a ma delete sysadmin

3 Likes

I experienced the same problem as above. I was configuring a new box and used an older img file (the latest available for Beaglebone Black). I ran raspbx-update and then went into the GUI and processed updates to do the 12->13 update. I did this yesterday and it worked fine.

A short while later I was loading another module and searched for updates again. I was offered an update that had just come out (so it appeared). I believe the module that was updated was FreePBX Framework and that it was going from or to 13.0.179 (it seems to have had a couple of updates yesterday.

After applying this update I experienced the same problem as the original poster, above. After applying the suggested fix above all symptoms went away.

I did not specifically choose to install the ‘sysadmin’ module. The series of steps I took was pretty plain-vanilla.

The sysadmin module shouldn’t even be downloadable on a Pi, as it’s ARM!

You’re saying your Pi randomly downloaded the Sysadmin module?

I had the same issue, also with a RasPBX install. The posted fix worked. I believe I did have Sysadmin loaded, either it sounded important or was required by another module.

I’m saying that the system may in fact have downloaded it for some reason. It was either part of what raspbx-update did, part of the package selection offered to me when I chose ‘update all’ or part of what was loaded when I went from FreePBX 12->13. – or perhaps it was just a reference to that package and not that package itself. Since three of us have experienced the same problem I’d say that something went wrong somewhere.

In my apache2 log I see this:

[Thu Sep 08 16:30:20.841285 2016] [:error] [pid 1818] [client 192.168.15.108:57344] PHP Warning: include(/var/www/html/admin/modules/sysadmin/functions.inc.php): failed to open stream: No such file or directory in /var/www/html/admin/modules/versionupgrade/Versionu

That is the ONLY line in ANY file in /var/log on my system that has the term ‘sysadmin’ in it. I did a case-insensitive grep on everything in /var/log

I’m not sure where the list of FreePBX package installs/removals is. If there is something else I should look for please let me know.

Edited to add:
I still happened to have the terminal log for when I ran the commands suggested above. It appears that the sysadmin module was not, in fact, loaded on my system. Check this out:

[email protected]:/var/log/apache2# a2enmod rewrite
Enabling module rewrite.
To activate the new configuration, you need to run:
service apache2 restart

[email protected]:/var/log/apache2# amportal a ma delete sysadmin

Please wait…

!!!amportal is depreciated. Please use fwconsole!!!
forwarding all commands to 'fwconsole’
The following error(s) occured:

  • Specified module not found

After I saw this I did a perfunctory reboot and the system (and GUI) came up fine.

OK, awesome. So all you needed to do was just in the other post - a2enmod rewrite and then service apache2 restart

Yes - that is correct. I enabled rewrite and restarted the service and all was well again.

Regarding the ‘custom install’ note above, this was about as plain-vanilla as an install could get. I’ve not even configured anything. I just loaded the system and performed some rather automated upgrades. Perhaps something else needs to check whether modrewrite is in fact enabled and enable it if it is not. I suspect, based on the fact that the people who reported this are all using raspbx, that the issue lies with that distribution.

1 Like