Web GUI Broken After Module Update

I did my update on 1st October PM (UK time). I’m not at my box right now, so can’t see logs to get a better understanding of the timings.

However, the bottom line is that I (and the others that were having the same issue) now understand what’s broken, and how to fix it. That’s the main thing!

Thanks for your assistance.

OK so the 2 other people this broke for was all done Oct 1st early morning which is when we pushed the wrong upgrade version into FreePBX for about 2 hours before it was caught and fixed.

I am unable to get this module to update correctly. it repeatedly creates a corrupted schmoozecom.conf file where the ports appear to be half segments of an ip address. I have my listening port set to a non-standard value, perhaps it doesn’t like this during the upgrade?

What sysadmin module version is it trying to install?

FYI I just updated the sysadmin module and have the same problem.

I tried instlling the update using module admin but got a message that the sysadmin RPM was too old and to run yum install sysadmin from CLI instead. Which I did and could no longer load the web page. Just looked for the /etc/httpd/conf.d/schmoozecom.conf file, it isn’t there.

So did the module update or did it tell you to upgrade sysadmin RPM first?

That file wont be their if the module is not updated. We added a sanity check that if the sysadmin RPM is to old it will not let you upgrade sysadmin module tell you update the RPM then you can come back and update the RPM.

The yum log shows an update to sysadmin-2.6.1-153_centos6.noarch. I am new to Asterisk, in fact Linux, so I am still learning how it works. All I know is I followed instruction to run yum install sysadmin and now I can no longer access the website for the server.

OK and then you did a update of the module after installing the RPM?

Just to compose the picture:

  • What is the result of:
    [font=Courier]yum list sysadmin[/font]
    in your system?

  • What is the result of:
    [font=Courier]ls -la /etc/httpd/conf.d/schmoozecom.conf[/font]
    in your system?

If you manually update the sysadmin module (via GUI or via CLI, which one method you prefer) then the schmoozecom.conf file should appear (file size: 469 bytes) on the file system with the content reported I posted before.


I updated today October 4th, the sysadmin- module to the new sysadmin- through CLI via this sequence (as root):

[font=Courier]/var/lib/asterisk/bin/module_admin showupgrades
/var/lib/asterisk/bin/module_admin upgrade sysadmin
amportal a r[/font]

I updated the sysadmin RPM too (I think it isn’t strictly mandatory if you yet have a very recent sysadmin RPM): I just saw that sysadmin-2.6.1-155 is out today (just after the -153) and, since I had the -152, I chose to give it a try.

AFAIK the -152 is very recent so I don’t know if a manual update (which always should be avoided) of that RPM should (or should not) be considered, at this point, required (all depends on what’s its installation history on your system).

In the end, in my system no troubles so far (the GUI is responsive as before).

The schmoozecom.conf is here as before (as yesterday) and only its time stamp was changed.

Tony, I just tried to update four different FreePBX Distro’s about 10 minutes (about 10am EDT on 10/4/2013) ago, and every one of them barked and failed on the sysadmin update.

All were Distro 4.211.64-7,64bit, and all were running sysadmin trying to update to When running the update all four systems generated the following:

Downloading sysadmin 165947 of 165947 (100%)
2.6.1 130_centos6 ERROR: Unable to install sysadmin. The sysadmin RPM you have installed is too old. Please update the sysadmin rpm via the command line, using yum install sysadmin
Error(s) installing sysadmin:
Failed to run installation scripts

I won’t just muck around and try and fix it, as sysadmin isn’t that critical to the normal running of the PBX, so if I can help at all with sorting this out, let me know.

Here you run the command

yum install sysadmin

You need to follow the warning that says go update the sysadmin rpm.

You need to do that with a yum install sysadmin from the Linux CLI.

It’s kind of funny, as I remember just being in a support case with your tech support, and them telling me that running yum independant of your update scripts, was a really bad thing to do, and could break stuff badly, so why I was reluctant to do it, but I will try and see how it goes…

As a follow-up, sysadmin updated via yum seems fine…

Anyone not able to get in, try port 9080. Then you can go into sysadmin and change ports back. There is supposed to be another update coming to fix this issue, but this is a good work around for now.


This is only on PBXiaF systems the port 9080 because of something they are doing.

We discourage people from doing blind yum update which updates everything. Doing a specific yum update sysadmin when directed by a module is fine.

This is needed to keep from breaking your PBX.

Thanks Tony. I appreciate the clarification. Thanks for all Schmooze Com does.