Web Callme feature with Asterisk 1.6

I have had this problem for a while and can’t figure it out.

I did the change in Manager.conf to add originate in read/write. I also have message polling enable on voicemail.conf. When I click the Call me button, the call goes through, but I don’t hear the message and in 10 seconds, the phone disconnects by the system telling me “Goodbye”.

Anyone has any ideas?

Asterisk :
FreePBX : 2.6.0
CentOS : 5.4 x64

I am getting the same issue. At first I couldn’t get it to dial at all, it always said, ‘The call failed. Perhaps the line was busy.’ but after adding in originate to the manager.conf, it now calls, but I hear nothing and then it hangs up. Any thoughts?

Same configuration as the OP.

Here’s some debug output, which is the reason why it’s not working, but I don’t know how to fix it yet.

Dec 1 10:20:32] WARNING[16685] pbx.c: The application delimiter is now the comma, not the pipe. Did you forget to convert your dialplan? (BackGround(/var/spool/asterisk/voicemail/default/203/Old/msg0000|MBOX=203&silence/2&vm-repeat&vm-starmain))

[Dec 1 10:20:32] WARNING[16685] file.c: File /var/spool/asterisk/voicemail/default/203/Old/msg0000|MBOX=203 does not exist in any format

[Dec 1 10:20:32] WARNING[16685] file.c: Unable to open /var/spool/asterisk/voicemail/default/203/Old/msg0000|MBOX=203 (format 0x40 (slin)): No such file or directory

[Dec 1 10:20:32] WARNING[16685] pbx.c: ast_streamfile failed on Local/[email protected];1 for /var/spool/asterisk/voicemail/default/203/Old/msg0000|MBOX=203&silence/2&vm-repeat&vmstarmain

It can’t find the file to play, of course it is there, but I’m guessing the formatting/syntax is incorrect and Asterisk can’t parse the data properly.

Fixed it:


Line 96:
$variable = “MSG=$new_path|MBOX=$from”;

Change it to:
$variable = “MSG=$new_path,MBOX=$from”;

That’s it.

Great job, thanx man. That seems to have fixed it. Thanks for all your help.

I have been looking for a fix for this for a long time. finally got it. thanks so much.