Way to control BLF LED color on GrandStream phones


We’re experiencing a frustrating issue with our GrandStream GXP-2010 phones, that all button/LEDs that are subscribed to a BLF are by default GREEN, and then RED when the phone is ringing. I’ve tried to communicate with GrandStream support, but they don’t want to do anything about it. The problem is that with 18 LEDs lit up in the default state, when nothing is happening, you can basically light up a room. I’ve put these all over my house, but you basically can’t have the phones in bedrooms unless you’re willing to permanently put a T-shirt over it. I’m not kidding, 18 LEDs on fire generate more light than a Disney night-light.

But I’m realizing that this may be something that can be hacked around in FreePBX or Asterisk. I don’t know which, so I’m posting here.

I don’t know much about BLF, but it seems that Asterisk sends various states to the BLF buttons, and it seems that whatever state Asterisk/FreePBX is choosing as the default state, is a state that GrandStream have chosen as a light up state. Of course, it’s idiotic for a phone to signal intensely when nothing is happening, it’s like me calling my wife every 2 minutes to say I’m fine.

Does anyone know in which file these states are chosen? I would like to try my hand at seeing if I can get Asterisk/FreePBX to send a different default state to the GrandStream phones, to get those (darn) LEDs to turn off, so they only light up red when they’re ringing, or something is actually happening.

Any help would be appreciated.