Warning, Upgrade to 2.9 alpha breaks CDR records

Hi all!,

Good Monday morning, I recently came across the news of FPBX 2.9 and decided to take the plunge and upgrade from and boy was that a mistake. Luckily for me I had followed my own instructions and did a mondo daily backup lol.

The result was this.

While 2.9 works, you lose CDR report functionality immediately, the page is blank and can not be fixed, I really tried everything.

I tried upgrading all modules, deleting all modules, re downloaded 2.8 and tried to reinstall on top of 2.9, which does not work, so I tried to re-install 2.9 which worked, but did not fix the issue.

The new features not really what I expected and I can go without for the time being until CDR reporting is fixed. This is very important!!! We need CDR access. Im not certain why the blank CDR screen, but the features all work. I check in asterisk cli and checked to see if they were actually being recorded, which they were just not viewable from the web interface.

So overall, its a work in progress. Look forward to 2.9 full release!

I also would like to add to Philippe’s admonishment not to run pre-beta code on a production machines.

The developers are hard at work making the next version of our FreePBX software. The last thing they need to be doing is spending cycles troubleshooting a production problem.

My advice is to wait a week after the beta, then try on in house or friendly user machine.

Watch the message traffic and bug tracker carefully so you know what you are getting in to.

We like production machines running alpha and beta code :slight_smile: It makes for some real life testing!

With that said, you obviously need to use proper judgement when doing such…

We use common designations of alpha, beta, rc (release candidate) to designate our level of confidence. Alpha means it has had limited testing and thus we need your help AND feedback to decide if it is really beta quality.

Beta means we feel pretty comfortable and in particular, previous functionality from earlier versions is most likely very stable. That means that upgrading a system, but not taking advantage of any new features is usually a reasonably secure thing to do.

RC (release candidate) means we’ve seen enough testing on beta versions to feel comfortable that this might be the real deal. Further exposure and watching the bug tracker will let us decide if it is ready to make final.

As always, and as was done in this case, backup your systems if you are going to take a production system for your testing.

the fix is not necessary.

Once you install the tarball just make sure to check for updates online and pull the framework update, it has the needed fix in it.

The issue was simply something that was introduced after the reports screen had been tested and verified working, and it was simple a name clash with a class in the CDR code that already existed.

Looks like something slipped in after the last round of testing just prior to the tarball coming out.


For now there is a new framework module, just update with Module Admin and this is addressed.

Cool, thanks for the quick response. and keep up the good work. Im not certain what happened but I will do further testing in a virtual machine lol, I cant have this happen again, otherwise looking good! I will setup a fresh install using my guide and i will first install 2.8 then upgrade to 2.9 and report back if this is still an issue, then i will implement the fix provided.

Quick fix, open up /var/www/html/admin/functions.inc.php, go to line 84 and comment that line out:

//table generation class
//require_once($dirname . '/helpers/table.php');

A new release will be out shortly


The CDR records work, though that’ snot to say there is not a bug somewhere.

There’s a file called /tmp/freepbx_debug.log which may have been created and if so, it may have some information in it wrt to errors. Also the normal httpd error logs.

The testing is appreciated, would be nice to try to understand what is up with your system though, as that is the idea behind this type of testing. I can tell you w have taken other production 2.8 systems and upgraded them to 2.9 without seeing this so very curious to see what the root cause is.