WARNING in IVR

Hello everyone,
How can solve the problem when i used ivr

– Executing [[email protected]:29] GotoIf(“SIP/701-000000b4”, “0?nodial”) in new stack
– Executing [[email protected]:30] GotoIf(“SIP/701-000000b4”, “0?skiptrace”) in new stack
– Executing [[email protected]:31] GosubIf(“SIP/701-000000b4”, “1?ctset,1():ctclear,1()”) in new stack
– Executing [[email protected]:1] Set(“SIP/701-000000b4”, “DB(CALLTRACE/11)=701”) in new stack
– Executing [[email protected]:2] Return(“SIP/701-000000b4”, “”) in new stack
– Executing [[email protected]:32] Set(“SIP/701-000000b4”, “D_OPTIONS=HhTtrI”) in new stack
– Executing [[email protected]:33] GosubIf(“SIP/701-000000b4”, “0?func-set-sipheader,s,1(Alert-Info,)”) in new stack
– Executing [[email protected]:34] NoOp(“SIP/701-000000b4”, "Blind Transfer: , Attended Transfer: , User: 701, Alert Info: ") in new stack
– Executing [[email protected]:35] ExecIf(“SIP/701-000000b4”, “1?Set(ALERT_INFO=)”) in new stack
– Executing [[email protected]:36] ExecIf(“SIP/701-000000b4”, “0?Set(ALERT_INFO=)”) in new stack
– Executing [[email protected]:37] ExecIf(“SIP/701-000000b4”, “0?Set(ALERT_INFO=)”) in new stack
– Executing [[email protected]:38] ExecIf(“SIP/701-000000b4”, “0?Set(ALERT_INFO=Normal;volume=)”) in new stack
– Executing [[email protected]:39] ExecIf(“SIP/701-000000b4”, “0?Set(ALERT_INFO=Normal;volume=)”) in new stack
– Executing [[email protected]:40] GosubIf(“SIP/701-000000b4”, “0?func-set-sipheader,s,1(Alert-Info,)”) in new stack
– Executing [[email protected]:41] ExecIf(“SIP/701-000000b4”, “0?Set(CHANNEL(musicclass)=)”) in new stack
– Executing [[email protected]:42] GosubIf(“SIP/701-000000b4”, “0?qwait,1()”) in new stack
– Executing [[email protected]:43] Set(“SIP/701-000000b4”, “__CWIGNORE=”) in new stack
– Executing [[email protected]:44] Set(“SIP/701-000000b4”, “__KEEPCID=TRUE”) in new stack
– Executing [[email protected]:45] GotoIf(“SIP/701-000000b4”, “0?usegoto,1”) in new stack
– Executing [[email protected]:46] GotoIf(“SIP/701-000000b4”, “0?godial”) in new stack
– Executing [[email protected]:47] Gosub(“SIP/701-000000b4”, “sub-presencestate-display,s,1(11)”) in new stack
– Executing [[email protected]:1] Goto(“SIP/701-000000b4”, “state-available,1”) in new stack
– Goto (sub-presencestate-display,state-available,1)
– Executing [[email protected]:1] Set(“SIP/701-000000b4”, “PRESENCESTATE_DISPLAY=(Available)”) in new stack
– Executing [[email protected]:2] Return(“SIP/701-000000b4”, “”) in new stack
– Executing [[email protected]:48] Set(“SIP/701-000000b4”, “CONNECTEDLINE(name,i)=test(Available)”) in new stack
– Executing [[email protected]:49] Set(“SIP/701-000000b4”, “CONNECTEDLINE(num)=11”) in new stack
– Executing [[email protected]:50] Set(“SIP/701-000000b4”, “D_OPTIONS=HhTtrII”) in new stack
– Executing [[email protected]:51] Macro(“SIP/701-000000b4”, “dialout-one-predial-hook,”) in new stack
– Executing [[email protected]:1] MacroExit(“SIP/701-000000b4”, “”) in new stack
[2019-03-06 14:30:30] WARNING[2382][C-0000008f]: chan_sip.c:24141 handle_response_invite: Re-invite to non-existing call leg on other UA. SIP dialog ‘3fdf490-1c3ea8c0-13c5-50022-3a2601-788bef14-3a2601’. Giving up.
– Executing [[email protected]:1] Macro(“SIP/701-000000b4”, “hangupcall,”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/701-000000b4”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] ExecIf(“SIP/701-000000b4”, “0?Set(CDR(recordingfile)=)”) in new stack
– Executing [[email protected]:4] NoOp(“SIP/701-000000b4”, " monior file= ") in new stack
– Executing [[email protected]:5] AGI(“SIP/701-000000b4”, “attendedtransfer-rec-restart.php,”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/attendedtransfer-rec-restart.php
– <SIP/701-000000b4>AGI Script attendedtransfer-rec-restart.php completed, returning 0
– Executing [[email protected]:6] Hangup(“SIP/701-000000b4”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 6) exited non-zero on ‘SIP/701-000000b4’ in macro ‘hangupcall’
== Spawn extension (ext-local, h, 1) exited non-zero on ‘SIP/701-000000b4’

The error problem is
WARNING[2382][C-0000008f]: chan_sip.c:24141 handle_response_invite: Re-invite to non-existing call leg on other UA. SIP dialog ‘3fdf490-1c3ea8c0-13c5-50022-3a2601-788bef14-3a2601’. Giving up.
THANKS

what kind of extensions are you using

I’m going to go with Chan_SIP as that is what is making the call.

What is the actual problem you are having? This output is for an extension, it looks like, that is making an outbound call. How is this in the IVR? There is nothing here to show a call going through an IVR.

As well the error you pointed to is for another channel on the PBX. Not the one you are showing. You need to provide a full trace of the call from the moment it comes into the PBX so we can see it go through the IVR.

what kind of MODEL extension are you using.

What does that mean?

It appears he is having problem delivering calls to a device. Being provided info on the device can help to determine, and gain insight, on the users situation.

So to clarify, what kind of extension are you trying to deliver the call to? Hardset model? Softphone model? What kind of hardset? Another PBX? Xlite?

Well first off, the claim is there is an issue with an IVR. The call trace that was provided is not a call inside an IVR, at all. It is a call being generated by a SIP channel, 701 to be exact, that is attempting an outbound dial. It’s all there in the call trace.

Second, the error that the OP put in bold from the call trace is for a call on another channel and not related to the actual call trace provided.

Third, nothing in the claim said the IVR was trying to send the call to an actual device. So how are you getting that this is an issue with a device being dialed?

Again the OP asked “How can the problem when I used ivr” and then did not describe the problem nor provide an actual call trace related to the problem in full. So my comment of “you need to provide a full call trace” and asking what the exact problem is was the proper path to take. Asking about random things like “are you using softphones or hardware phones, etc” is just the wrong path based on the information presented.

I am (like most everyone on here who answer questions) just trying to help users. In this case I am tryin to get some information out of the OP setup. Don’t scold the community for trying to provide this help, it very unnecessary.

1 Like

That was a scolding? No my dear boy that wasn’t a scolding. That was correcting your poor line of support questioning and pointing out why it was incorrect. If being corrected constitutes being scolded these days, no wonder everyone is so sensitive.

Well, hopefully you can get to the bottom of the problem with the OP! Hopefully it will be a well documented repair processes for everyone to learn from!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.