Warning: Cannot connect to online repository(s) (http://mirror1.freepbx.org,http://mirror2.freepbx.org). Online modules are not available

I have an existing FreePBX 12.0.76.2 system. I tried to upgrade it a couple of times with disastrous results leaving our company with no phones until I was able to restore to the old configuration. I decided to take a different approach and try to transition to one of the pre-built Sangoma systems running version 13.0.113. The system wasn’t able to get an IP with DHCP for some reason so I assigned it an unused IP address inside my network. Currently it has only the one NIC connected and it’s connected to a switch inside my network. I aborted the Smart Firewall wizard because it wants to be in the DMZ and for my system with only internal phones that didn’t seem like the route for me to take.

I was then able to access the GUI but I notice an error in red in the top right corner “Can Not Connect to Asterisk”. Thinking perhaps doing updates would fix that problem I attempted to run the “Check online” however I get an error “Warning: Cannot connect to online repository(s) (http://mirror1.freepbx.org,http://mirror2.freepbx.org). Online modules are not available.”

Having searched for a solution to that issue I found the suggestion to run

" var/lib/asterisk/bin/freepbx_setting MODULEADMIN_SKIP_CACHE 1 && amportal a ma upgrade framework && /var/lib/asterisk/bin/freepbx_setting MODULEADMIN_SKIP_CACHE 0`" which gives me the results "!!!amportal is depreciated. Please use fwconsole!!!
forwarding all commands to 'fwconsole’
No repos specified, using: [standard,commercial] from last GUI settings

> Starting framework download..
> Processing framework
> Verifying local module download...Redownloading
> The following error(s) occured:
>  - Unable to connect to servers from URLs provided: http://mirror1.freepbx.org/modules/packages/framework/framework-13.0.113.tgz,http://mirror2.freepbx.org/modules/packages/framework/framework-13.0.113.tgz"

Thinking this might still be a firewall issue from the Smart Firewall I went to Module Admin and Uninstalled it since I can’t find anywhere else to disable it, then tried again but the results were the same so I reinstalled it again.

Now I’m thinking it’s a DNS problem as I can’t ping anything outside my local network but both my ISPs DNS and Google’s 8.8.8.8 are in my DNS nameserver list.

Rebooted the machine… again… .and this time it pulled a different IP address than the one configured earlier and now it see the updates. So… problem solved.

Problems that go away by themselves come back by themselves…

Normally I would agree but since it appears there was an error between the IP and DNS, and that the IP was then changed in the GUI where it stuck, in this case I think that particular problem won’t be back. I was able to update all modules to their current versions. Now I just need to figure out how to get my setting from my old 1.818.210.58-1 system into the new 10.13.66-17 system. I fear that will be a bigger task.

Have I got some good news for you…

Basically, run ‘curl -s https://convert.freepbx.org | bash’ on both machines (new machine first), and then pretty much everything happens automatically.

If you want to try some alpha code that does a lot more modules (most of the commercial and unsupported modules), I can send you a PM here on the forums with a different URL to try.

I chatted with Sangoma this afternoon and they told me this isn’t possible. They said to go to a version this far back I must manually enter all my settings again, that scripts can’t be used.

It’s the weekend here so I’m putting this aside until next week but I’d sure be interested if there’s a way to avoid days of looking at one screen and checking the box on the other (old system vs new one).

The page you sent me talks about Elastix and PBX in a Flash. It works with old versions of FreePBX too? How many of the settings aren’t going to transfer over?

I would suggest you give it a try and see. Elastix and PBX In a Flash are old versions of FreePBX.

The full answer is ‘most’ for the current release, and ‘almost everything’ for the alpha. This doesn’t touch your existing machine, so you can try it now without any danger to production.

Distro ver 1.818.210.58 should be running FreePBX 2.10, which will work with the migration script Rob linked.
There is no easy way to upgrade in place the old server, could this be what you were told?

1 Like

I don’t think so. I was very clear that I had purchased a new Sangoma built system which I was going to replace the old system with so I was wanting to move the settings from the old machine, running the old FreePBX, to the new machine running the new FreePBX. That seems pretty clear to me that I wasn’t trying to stay on the old machine.

I’ll try to find time today to read up on the page Rob sent me to.

The instructions say the new system needs to be running Distro 10.13.66, is it OK if module updates have also been done or will this create errors? I’m currently running 13.0.190.7 on the new machine.

And does it matter if the machines are located behind firewalls? In my case the machines are behind pfsense firewalls and then internal routers and are not in the DMZ as we don’t have remote phones to connect with. Will the scripts run under those conditions?