Warm Spare Backup Not Showing in GUI after Save and Run

I followed the wiki directions for warm spare and they worked like a champ. I created the backup on the standby server, saved it, ran it and it worked. I wanted to go back into the backup I created a make a change but that backup I had created is not visible in the web gui. All I see is the default backup. When the backup restores does it erase the backup I created?

It is necessary to config the backup with “Exclude Backup Settings” on the warm spare or the backup settings from the primary will overwrite all backup jobs on the spare. It’s noted on this page:

1 Like

For this task we will drag “Full Backup” and “Exclude Backup Settings” to the backup items on the left.

I really need to work on my reading skills. Thanks for the help. I was surprised at how smooth and easy the setup was. And the restore was perfect. It’s ok if I don’t include the cdr as part of the backup right?

Easy to miss, don’t ask how I knew the answer. Will will make that more prominent now.

Yes, provided you don’t need them backed up. Another option is to create a separate warm spare job just for the CDRs that runs on a less frequent schedule.

1 Like

Great idea. Thanks!

I see there are a few options regards to NAT and Bind Address when the restore happens. What combination of those will allow my warm spare to stay at its current IP (not switch to the primary server ip) but also grab the Asterisk SIP Settings Local Networks. The primary server has about 30 different local subnets that I want to bring over without changing the static lan ip of the backup server

Nevermind. I’ll just program in the subnets into the warm spare and have it excluded on the backup.

You may not need to specify them all in Local Networks. All that’s used for is to determine whether an address is directly reachable or is NATted.

For example, if you have subnets 192.168.1.x, 192.168.7.x and 192.168.13.x you could just specify
which would cover all of them. It would also ‘incorrectly’ cover e.g. 192.168.2.x, but that is irrelevant, because such an address is not routable on the internet and would never be seen by the PBX.

If you have NATted VPNs with private WAN addresses, then you do need to exclude them from Local Networks, but you may also need multiple transports so Asterisk knows which WAN address to substitute and/or a customized route table.

1 Like

That is a great idea that I never thought of. I used something similar when setting up a static route for eth0 but hadn’t considered using that here as I have 18 different LAN subnets and when a new one pops up that phone has one way audio until I fix it. Thank you

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.