Wanpipe yum update gives fatal error

I received this error this AM when running a yum update on a freepbx system.

Installing package(s) with command yum -y install wanpipe ..

Loaded plugins: downloadonly, fastestmirror, kmod, priorities
Loading mirror speeds from cached hostfile

  • Webmin: download.webmin.com
    Setting up Install Process
    Resolving Dependencies
    –> Running transaction check
    —> Package wanpipe.x86_64 0:7.0.0-kernel. will be updated
    —> Package wanpipe.x86_64 0:7.0.2-kernel. will be an update
    –> Finished Dependency Resolution

Dependencies Resolved

Package Arch Version Repository

wanpipe x86_64 7.0.2-kernel. pbx 13 M

Transaction Summary

Upgrade 1 Package(s)

Total download size: 13 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : wanpipe-7.0.2-kernel. 1/2
FATAL: Could not open ‘/boot/System.map-2.6.32-279.11.1.el6’: No such file or directory
Found existing Wanpipe configuration…
*** Sangoma Wanpipe was successfully installed.
Hardware Probe: /usr/sbin/wanrouter hwprobe
Wanpipe Config: /usr/sbin/wancfg_fs
Wanpipe Start : /usr/sbin/wanrouter start

Cleanup : wanpipe-7.0.0-kernel. 2/2
Verifying : wanpipe-7.0.2-kernel. 1/2
Verifying : wanpipe-7.0.0-kernel. 2/2



I am not sure but a fatal error seems to me out of place for an official update to an unmodified distro.

Not sure on that. Those are new packages from Sangoma as they provide the stuff. I would reach out to them.

Am I to infer from this suggestion that the FreePBX distro team releases upstream package updates without any disro level quality control?

Not at all. We test all packages and I updated wanpipe on 3.211.63 32 and 64bit and the same for 4.211.64 and did not have any issues.

I talked with Sangoma and they said

“It is not anything to worry about.” as the drivers still get installed.

Strange then. The update is looking for the ix86 version system map and of course I have the x86_64 version instead.

. . . FATAL: Could not open '/boot/System.map-2.6.32-279.11.1.el6': No such file or director . . .

ll /boot/System.map*
-rw-r–r--. 1 root root 2342243 Oct 16 2012 /boot/System.map-2.6.32-279.11.1.el6.x86_64

I cannot imagine how the repo configuration would permit that to happen only on my system.

I just brought up another dev box and tested. I see the same error but the RPM installs fine which is why our testing servers did not report any issues. Sangoma has told us the error can be ignored but they will look into it.