VQ Plus Queue Penalty Rules not working

I purchased VQ Plus to make our queue penalties work similar to what is described in the Queue Penalty Rules of the VQPlus-Module-UserGuide.pdf. There seems to be an issue right from the start as when selecting Enable and a value of zero for the Initial Min/Max Penalties when submitted the Enable checkbox is no longer selected. Changing the Initial Min/Max Penalties to 1 does not automatically unselect the Enabled box.

With the above in place, I then adjusted the penalty for the dynamic agents and Queue Penalty Rules accordingly. The Queue Penalty Rules do not seem to work. The agents with the lowest penalty (1) ring but after 30 seconds, agents with a penalty of 2 do not ring. My Queue Rule table has two entries “3, 1, 0” and “30, 2, 0”.

Versions:
Currently running FreePBX 13.0.192.19.
Queues 13.0.34.14 Stable Sangoma Technologies Corporation GPLv2+ Enabled and up to date
Queues Pro 13.0.42.2 Stable Sangoma Technologies Corporation Commercial Enabled and up to date

Queues:
asterisk -rx “queue show 799”
799 has 0 calls (max unlimited) in ‘ringall’ strategy (0s holdtime, 0s talktime), W:0, C:0, A:7, SL:0.0% within 60s
Members:
agent 1 (Local/[email protected]/n from hint:[email protected]) with penalty 2 (ringinuse enabled) (dynamic) (Not in use) has taken no calls yet
agent 2 (Local/[email protected]/n from hint:[email protected]) with penalty 1 (ringinuse enabled) (dynamic) (Not in use) has taken no calls yet
agent 3 (Local/[email protected]/n from hint:[email protected]) with penalty 1 (ringinuse enabled) (dynamic) (Not in use) has taken no calls yet
No Callers

Any ideas? Is this following doc current?
http://literature.schmoozecom.com/vqplus-module/userguide/VQPlus-Module-UserGuide.pdf

Thanks!
Jim

I did not open the PDF file… I believe the Wiki is the most up to date.

See all VQ Plus/Queues Pro sections.
https://wiki.freepbx.org/pages/viewpage.action?pageId=8421516

Another note, this is a commercial module and has free support at support.sangoma.com

Thanks! I was not aware of the free support for commercial modules.

Have you been able to find a solution? I am seeing the exact same issue here.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.