Voxzone Card

Asterisk: 1.4.21.2
FreePBX: FreePBX 2.5.0.0
PCI Card: Voxzone X100P (FXS)

Hello all, I’m trying to test out this Voxzone card. Under “lspci” I can “see” the card, but it just comes up as an unknown Motorolla. I created an inbound route, but Asterisk doesn’t see any call coming in. Is there a way to tell if the driver “took” onto the card? Or is the fact that is comes up as unknown tell you, “Hey, there’s no driver associated with it.”?

By the way, I installed the card first and then installed PBX in a Flash.

Have you run genzaptelconf from the command line? If you have, see if your card info is in a file called zapata-auto.conf. If it is, open zapata.conf and add the following line:

#include zapata-auto.conf

Do an amportal kill and an amportal start to re-read the conf files. Then open the CLI and issue the command:

zap show channels

If your channel shows up, you are done. If not, post us again with some debug stuff.

Thanks for the response…here’s what I got:

login as: root

[email protected]:~ $ genzaptelconf

STOPPING ASTERISK
Asterisk Stopped

STOPPING FOP SERVER
FOP Server Stopped
Generating '/etc/zaptel.conf’
Generating '/etc/asterisk/zapata-auto.conf’
Unloading zaptel hardware drivers:.
Loading zaptel framework: [ OK ]
Waiting for zap to come online…OK
Loading zaptel hardware modules: tor2.
wct4xxp.
wcte12xp.
wct1xxp.
wcte11xp.
wctdm24xxp.
wcfxo.
wctdm.
wcusb.
xpp_usb.
No hardware timing source found in /proc/zaptel, loading ztdummy
Running ztcfg: [ OK ]

SETTING FILE PERMISSIONS
Permissions OK

STARTING ASTERISK
Asterisk Started

STARTING FOP SERVER
FOP Server Started
Chan Extension Context Language MOH Interpret
pseudo from-zaptel en default


If I read this right it means it didn’t “see” the card, right? It’s not in zapata-auto.conf. here’s what’s in there:

; Autogenerated by /usr/local/sbin/genzaptelconf – do not hand edit
; Zaptel Channels Configurations (zapata.conf)
;
; This is not intended to be a complete zapata.conf. Rather, it is intended
; to be #include-d by /etc/zapata.conf that will include the global settings
;
callerid=asreceived

; Span 1: ZTDUMMY/1 “ZTDUMMY/1 (source: RTC) 1” (MASTER)

You are correct. It does not appear to be seeing the card. I know you wish to buy the cheap card, but this is one example of why I use Sangoma’s cards, they just work.