Voxbeam Inbound Trunk Issues

Hello FreePBX Community,
I need your help with an inbound issue on my Voxbeam trunk.

Outbound calling is testing and working great on the trunk. Inbound calling is the issue. The customer service team at Voxbeam said:

In order to assist you on this concern, we tried to call one of your DIDs which is 12629012559 and we noticed that our calls coming from our DID server 95.211.119.240 is sending the call attempt to your SIP endpoint 174.100.169.174 but it is not responding. May we kindly ask if you could allow calls from our IP 95.211.119.240?

I’m not sure what setting i have incorrect. I’m using chan SIP on port 5060. Voxbeam has also said:

Our DID server doesn’t require registration. Just configure your Asterisk incoming context that would specify your server what to do when our DID server is sending calls coming from your DID number. Unfortunately, we cannot provide a very detailed instructions since every switch configuration differs on its infrastructure and it’s already beyond our scope.

Does anyone have an indication as to why outbound would be working but no inbound from any DID i have in my voxbeam account? I do have an inbound route set up from DID 12629012559 to ring to one of my extentions. When i call any DID on my account I get a the voxbeam guy ‘all circuits are busy now…’ after several ring…pause…ring patterns.

Thank you in advance for your help with this one.

I found an Asterisk config guide for Voxbeam:

Asterisk is an open source PBX designed to
connect callers with the outside world over IP,
analog and digital connections. The information
details below should help guide you on
configuring and connecting to Voxbeam
using Asterisk.
Settings:
After installing Asterisk, change to this directory:
etc/asterisk and locate the sip.conf file. Check and see
if you have the settings listed below in this file.
[general]
port=5060
bindaddr=0.0.0.0
qualify=no
disable=all
allow=alaw
allow=ulaw
allow=gsm
dtmfmode=rfc2833
srvlookup=yes
Next, add these settings below and modify them to
your specifications for inbound and outbound calls .
[voxbeam_outbound]
type=peer
insecure=very
nat=no
canreinvite=no
username=your_name
secret=your_asterisk_password
host=sbc.voxbeam.com
context=voxbeam_outbound
[voxbeam_inbound]
type=peer
insecure=very
nat=no
canreinvite=no
username=your_name
secret=your_asterisk_password
host=95.211.119.240
context=voxbeam_inbound

I’m sorry, I don’t know where to check if i have these settings correct in the FreePBX GUI. Can you help? Thanks so much!

All the information you need Is there, but do NOT try to follow the instructions at the top of that FAQ.

Set up a trunk - call it VoxBeamTrunk.

In your “general chan_sip” settings, use the settings from ‘[General]’.

In the trunk, there are two sections, one for the Peer settings and one for User settings. Your NAT settings will be set up at the top level of the SIP settings. If you are using NAT, the setting will be Yes and the External Address will be your external IP address (174.100.169.174).

These are your Peer Settings:

type=peer
insecure=invite,port
host=sbc.voxbeam.com
context=from-internal

These are your User Settings:

type=peer
insecure=invite,port
canreinvite=no
host=95.211.119.240
context=from-pstn

If your outbound connection uses a username and password, you’ll need to add those back in.

If you are using FreePBX 13 or later, you will also need to make sure that the incoming connection from the VOIP Provider is allowed through the firewall.

1 Like

Dave,
This worked perfectly. thanks for the guidance. All routes now functioning.

Hey, one more question. Do you know how to auto root login to freepbx? Whenever the power goes out here I have to login to the pbx from the console which is in the basement level. If the power trips, I’d love for the pbx to come back online automatically where i can ssh or gui into it. Does this make sense and do you know how to set this up?

thanks again for all your help bro!!

I set the BIOS to return to power on after power loss. After that, you should be all set.

1 Like

Are you talking about the motherboard BIOS or the freepbx bootstrap? Even after powering up, it will still require root login, correct? That’s what i’m trying to workaround. The root login at the console. I want that to automatically happen. Any ideas?

No. A properly configured PBX does not require any manual intervention on boot. What do you do after logging in?

It comes up with the linux login where you have to set user to ‘root’ and then enter the root password. then it logs in to freepbx and i can use the web gui and ssh. I’m looking to bypass this process. The building that i’m in loses power a lot.

The login is unnecessary, all services on the pbx run regardless of whether a user is logged in or not.

The login is necessary. When the building loses power and my network shuts off, once power comes back on, i cannot use the gui or ssh into my pbx unless i re-login to the pbx as root user. that’s what boots freepbx and the gui.
It makes me do that at the console which is in the basement. I’m looking to bypass that process.

That makes no sense, there are no services necessary that are not started automatically. and logging in would not start anything unless you really understood what you are doing and did it.

Nope. That’s not how the system works.

If your system is doing that, you definitely have a misconfigured server.

Once the power comes back on, and the machine powers up, the Linux startup script executes and starts up all of the “services”. The PBX should be part of that in a properly configured system. Simply logging in as ‘root’ at the console will not do anything like what you are describing unless you deliberately set the system up to do that.

Now, if you log into the console as ‘root’ (which you should be able to do from any computer in the network using SSH), you CAN manually start or restart the system using “fwconsole restart”. If the service is not running when you do that, you’ll get a short gripe that the service isn’t running and the server should then start the service.

Logging into the GUI requires the PBX be up and running and the web service to be running. Without both of those, you can’t get into the PBX GUI to do anything with the service.

I’ll check my settings and see what’s up. THank you guys.