Vonage and FreePBX/Asterisk not working

I have a Vonage Softphone line, and I got instructions on how to get it to work as a SIP Trunk in FreePBX/Asterisk. However, when I attempt to call out, I get a “All Circuits are Busy Now” message. It will not even try to place the call. I got the code from http://www.pbxinfo.com/asterisk-systems/21509-vonage-softphone-line-trunk-asterisk.html . I also saw http://www.voip-info.org/wiki/view/Asterisk+and+Vonage but I did not know what the author meant by his “sip.conf”. Can anyone help me? It will be much appreciated!
Logs:
[email protected]:~ $ asterisk -r
Asterisk 1.4.21.2, Copyright © 1999 - 2008 Digium, Inc. and others.
Created by Mark Spencer [email protected]
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for detail
s.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

Connected to Asterisk 1.4.21.2 currently running on pbx (pid = 3940)
Verbosity is at least 3
pbx*CLI> sip show registry
Host Username Refresh State Reg.
Time
sphone.vopr.vonage.net:5061 18433144226 120 Unregistered

pbxCLI> sip show peers
Name/username Host Dyn Nat ACL Port Status
4357 (Unspecified) D N 0 UNKNOWN
2002 (Unspecified) D N 0 UNKNOWN
2001/2001 192.168.0.199 D N 46434 OK (13 ms)
3 sip peers [Monitored: 1 online, 2 offline Unmonitored: 0 online, 0 offline]
pbx
CLI>
[email protected]:~ $

cant help without some logs…

asterisk -r

sip show registry
sip show peers

please post those

Posted 3:34pm 10/26/08

ok, your sip is not registered with vonnage and your 2 peers are not connecting…

check your registration string

and check your host = settings for the sip trunk

With what you said about the peers, I had one extension online at the time, and two others offline. How could I get the SIP registered? Check what part of the registration string? What should the host= settings be? Thanks!

Ok, I got it working. The line is connected now. I had some port forwarding issues. Anyway, incoming calls are fine, but I can not place outgoing calls. I get a message saying that the number is invalid, but it is not from the Asterisk system. Could I have some dialing rules screwed up? Any ideas?

what do you have for your outbound dialing rules?

Is this the only outbound line?

if so and you do not have a local number from vonage - everything needs to be dialed 1NXXNXXXXXX

I see that I have Vonage is connected to my Asterisk Distro. It is showing on the IP routes on line.

I can make internals calls, I can also use the intercom. All of the part is doing fine.

I have believe I have my outbound routes set up right from what I have read. But I am getting “all circuits are busy now please try you call again”

I have read a lot of post and tried to do what they have mentioned. Does anyone have a idea of maybe what I might have set up wrong in a newbie way to understand.

I am getting one error, and that is “cannot load FOP server” I have been working on this also and believe I just about have this fixed. Could this be the issue?

Thanks you in advance.

I have a local number and I am getting the same message. Could you share some of your setups. We have worked on this for weeks and not luck. Please anything I am sure would be a help.

I have read a lot of post where others are having this same problem, even goggled it and found others having the same problems, but dont see any one having a way or if they did solve this problem.