Voipfirewalld using ~99% CPU

Hi,

Since I can’t see any threads about this elsewhere, I’m assuming it’s me and so trying to debug the issue.

I’m currently using FreePBX 14.0.3.2 and running version 13.0.55.1 of the System Firewall module.

For the past two weeks, it looks like voipfirewalld has been almost 100% CPU which is then slowing down the web interface and (I assume) everything else.

# uptime
 11:22:31 up 10 days,  1:13,  1 user,  load average: 4.32, 4.64, 5.00
model name	: Intel Xeon E3-12xx v2 (Ivy Bridge)
cpu MHz		: 2499.998

My questions would be:

  • Is anyone else seeing anything similar with their setups
  • What would be the next step to debug this issue?

I’m relatively new to managing FreePBX so let me know if I can give any more information here and I’ll try to fetch it.

Cheers,
Jamie

Rolling back to 13.0.52 fixes this issue, all versions after this seem to have the CPU problem.

3% total CPU usage

fwconsole ma downloadinstall http://mirror1.freepbx.org/modules/packages/firewall/firewall-13.0.52.tgz

99% total CPU usage:

fwconsole ma downloadinstall http://mirror1.freepbx.org/modules/packages/firewall/firewall-13.0.53.2.tgz

CC: @xrobau - I’m happy to help debug but I’m surprised to be the only one posting about this at the moment

You should be using 13.0.55 or higher.

Hi Rob, cheers for the reply. As noted in the OP, I was using 13.0.55.1 which was also using all of the CPU.

I’ve tried all versions one by one down to 13.0.52 with little success until the final version.

Very odd. Which process is using all the CPU? And can you paste the last 100 lines or so of /tmp/firewall.log to pastebin.freepbx.org please?

I’ve upgraded to 55.1, the CPU shot up right away.

The process is voipfirewalld (Monitor Thread) - the PHP file it’s actually running from is admin/modules/firewall/hooks/voipfilewalld

Logs are here but those appear to just be initial iptables settings when the module is enabled.

Let me know if I can be of any more assistance.

I’ve tried the latest 55.3 update but the issue still persists I’m afraid.

Happy to report that version 13.0.56 has fixed the issue! Cheers @xrobau!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.