Voip provider has 2 host ip addresses for incoming calls How to configure for both?

I have FreePBX 13.0.163
I am trying to use a VoipStunt SIP trunk.
It works but it only works if I match the correct IP “host” address, they, voipstunt, seem to use two different ones. and
I have had a look around here and the web and either I have missed something or I have not understood, unsure right now.
I have tried putting in two host entries and Freepbx made it look like this; " host=", it only worked for one of these unfortunatly.
I have tried to make two separate trunks, one for each but one of them always stays disabled.
I have spent a fair while on this and have had to use restore a few times when I did something to annoy the system but that has been very good at getting me back to where I was.

I get an incoming call, it either says "rejecting unknown SIP connection from …
or it works. it depends if I have the correct ip address in the incoming host entry.
problem, I need both ip addresses unless you know better.
I don’t want to use anonymous it appears. I only have a domestic set up so no fancy kit to play with.

I hope this makes sense and if I have missed something really obvious, sorry, any information I need to give to help, please ask me, thanks.

For incoming?

Build two trunks. Call one “VOIP Stunt Primary” and the other “VOIP Stunt 2”.

You can have as many trunks as you want. Set them up identically with different host IP addresses.

Thanks, I think I have tried this but I will revisit.
Last time the second trunk stayed disabled.
I hope this time I can knock it out knowing it should work.
I will have another go, tomorrow, and let you know. Thanks again. Peter

Hi, I have tried this now.
My first attempt I used the “host=sip.voipstunt.com” in both outgoing trunks and the ip addresses in the incoming section, this did not work, one trunk always disabled.
After your feedback, I tried changing this using, for the outgoing section, using host= in one trunk and host= in the other, no change.

Spurred on by the fact you said it should work, I deleted both trunks, re-added and they both became active and despite some issues around my devices being a bit touchy, or going unreachable, I was able to get incoming calls without the problem.
Just need to sort out my local problem and should be OK.

So, thank you.
Seems I needed to use just the ip address not the name and as with a lot of kit, delete and re add.

At this time I guess this is closed. new to this so don’t know if I can do this or it just happens?
Ta, Peter

Was it possible you were using the same name for the Trunk Name on the SIP Settings, Outgoing tab? That would cause one of them to be disabled.

Hi, thanks,
No, sorry, I made the outgoing settings the same for both, using the name for the “host=” settings but the trunk names in both General and SIP settings were, and are different so I have no idea.
At this exact moment my ISP is giving me about 1meg, lucky I don’t run a business?, and until that is resolved I have basically shut down.