Voicemails aren't being sent to email

My boss use to handle Asterisk, but he passed away about a month ago. So, I am forced to learn our phone system. My question is we use to get emails with voice mails sent out, but recently that stopped. So, was wondering if someone good point me in the right direction to start or how to fix it. Just trying to give the end user their voice mails via email instead of just the phone.

(Debian squeeze/sid)
FreePBX version: (2.8.0)

Thanks

When I look at the voice mails they are being received, but not being sent out and in the log it says error 451 Name Server Timeout. Where in settings can I find out the Name Server that is being used?

Thanks

cat /etc/resolv.conf

Mr. Carlsson you are the man!!! Thanks so much inside that file was our old nameserver ip’s so I went in and changed it everything is working fine now.

Thanks,

Rian

I don’t know Debian and even if I did I could not possible talk you through all the permutations.

I would suggest you find a Linux guy to help you.

IMHO this is out of the scope of the FreePBX forum.

I’m a complete dummy to this SkykingOH sorry, I wouldn’t know where to look are what command to run. I only know how to log into Webmin and poke around on it. Is there a command I can type that will let me know what I am running for Email or can I find that out through Webmin?I want to say it’s running sendmail, but I don’t want to lie to you.

The email functionality is part of Linux. Are you running sendmail, postfix or something else?

Have you checked your mail log files?

Can you send email from the command shell?

Hi Mike,

I’m an ex Elastix user. In their networking tab they have you put the domain name. I used to put pbx.mydomain.com, and that’s where emails would appear to come from.

Sometimes I would have to monkey around with main.cf

I am going straight FreePBX now and am confused on some things.

last night I was getting this error on vm:em in /var/log/maillog

Sep 2 22:49:06 localhost postfix/smtp[18043]: 34CE36171143: host mx00.1and1.com[74.208.5.3] said: 421 invalid sender domain ‘localhost.localdomain’ (misconfigured dns?) (in reply to RCPT TO command)
Sep 2 22:49:06 localhost postfix/smtp[18043]: 34CE36171143: to=[email protected], relay=mx01.1and1.com[74.208.5.21]:25, delay=1.5, delays=0.02/0.04/1.2/0.23, dsn=4.0.0, status=deferred (host mx01.1and1.com[74.208.5.21] said: 421 invalid sender domain ‘localhost.localdomain’ (misconfigured dns?) (in reply to RCPT TO command))

So I looked at my Elastix box’s resolv.conf
which showed this
nameserver 8.8.8.8
nameserver 4.2.2.2

and I put the above in my FreePBX 2.9 resolve.conf

/etc/sysconfig/network has this:
NETWORKING=yes
NETWORKING_IPV6=yes
HOSTNAME=testpbx.mydomain.com

In my GUI SIP settings I have NAT checked yes; IP Configuration=Static IP, with External IP and Local Networks set properly.
In sip_nat.conf I have NAT rules the they are all commented out. (used to have to have these uncommented in Elastix, but I see the GUI does it now, and I get a big red error box if they are uncommented.)

Now I get this error in maillog:

Sep 3 08:14:43 localhost postfix/smtp[20016]: DAB74617114C: to=[email protected], relay=mx01.1and1.com[74.208.5.21]:25, delay=0.67, delays=0.02/0.01/0.64/0, dsn=4.4.2, status=deferred (lost connection with mx01.1and1.com[74.208.5.21] while performing the HELO handshake)

in /etc/hosts I have

Do not remove the following line, or various programs

that require network functionality will fail.

127.0.0.1 localhost.localdomain localhost
127.0.0.1 testpbx.mydomain.com localost localhost.localdomain
::1 localhost6.localdomain6 localhost6

So I’m trying to do two things.

  1. get the HELO handshake error to stop
  2. make vm:em work
  3. and related to 2, make it appear to come from my domain
  4. make my command line not say [email protected]

Thanks.