Voicemail to Multiple Emails

I saw a note that Asterisk is supposed to allow multiple email addresses for emailing voicemails separated by commas. But when I enter this in FreePBX, FreePBX puts the second email address down in the pager box. Using a space to separate them doesn’t work.

Any Ideas?

What version of FreePBX are you using? Works for me using commas.

Handle it at the server, create an email group and use that in FreePBX instead.

Pro/Con? Personal preference I guess, but if only one address is working for you, then using a group is the way to go. Depends on your email service of course.

13.0.105. I’ve tried this in both Chrome and Firefox. When I select submit, the second email address moves to the pager box.

Matphillips, yeah I could setup an alias at the OS layer. But why is this happening? It would be so much more simple to just add two addresses to the email box.

I was able to create a comma separated list of email addresses. I was using the voicemail tab under the extensions app.

safari if that matters.

But, when I try it in UCP, it behaves as you mention… overwriting the pager field back in the extensions view of the admin panel.

I also was trying via extensions not UCP.

Right you are! That worked for me. Applications | Extensions worked while Settings | Voicemail Admin exhibited the problem I described. Everything is working as expected. Thanks.

File a ticket at issues.FreePBX.org, the behavior should be consistent.

I submitted 12086 in the issues database.

1 Like

Excellent. It also looks like a space after the comma must be avoided.

This is what I love about cats. There are a dozen ways to skin them.

For those watching the topic, the ticket was updated to say it is addressed in voicemail v13.0.45

I won’t have a chance to test this week.


If you are using a framework version of 13.0.96+
To enable the edge track, go to “Advanced settings and set
“Set Module Admin to Edge mode” to “Yes”
Then go to module admin and click “Check Online”. Note this will show updates
for ALL modules in the edge track. Update the module(s) relevant to your issue.
Once finished go to “Advanced settings and set “Set Module Admin to Edge mode” to “No”
You may also upgrade from the command line with "fwconsole ma --edge upgrade MODULENAME"
replacing MODULENAME with the modules rawname which can be seen in “fwconsole ma list”