Voicemail to Email inconsistent

I am not getting consistent functionality from the voicemail emails. the issue is the sending email address and sender name and also the custom message. I have edited the include files and tried uncommenting them out and commenting them out but the emails still come from “Asterisk PBX”. It has worked for a while, but then keeps coming back to that. The funny part is that the “[PBX]” prefix is gone from the subject line as selected in the config files.

I have tried searching to see if anyone else was having this issue, but maybe I have not used the best search terms.

Asterisk & FreePBX 2.6.01

New to Asterisk, not new to Linux or phone systems but not an expert either.

Thanks for any help or suggestions.

Configs posted below:


include vm_email.inc
include vm_general.inc

4980 => 8376,Mark xxxxx,[email protected],attach=yes|saycid=no|envelope=yes|delete=no



; 1st listed format gets emailed

pbxskip=yes ; Don’t put [PBX]: in the subject line
[email protected] ; Who the e-mail notification should appear to come from
fromstring=Voicemail System ; Real name of email sender
maxmessage=180 ; max length of vm message
minmessage=3 ; Minimum length of a voicemail message in seconds
maxsilence=5 ; Wait for 5 silent seconds and end the voicemail
silencethreshold=128 ; What do we consider to be silence
skipms=3000 ; How many miliseconds to skip forward/back when rew/ff in message playback
review=yes ; Allow sender to review/rerecord their message before saving it
operator=yes ; Allow caller to press 0
nextaftercmd=yes ; Automagically play next message when current message is deleted or saved


; Change the email body, variables: VM_NAME, VM_DUR, VM_MSGNUM, VM_MAILBOX, VM_CALLERID, VM_DATE

emailbody=${VM_NAME},\n\nThere is a new voicemail in mailbox ${VM_MAILBOX}:\n\n\tFrom:\t${VM_CALLERID}\n\tLength:\t${VM_DUR} seconds\n\tDate:\t${VM_DATE}\n\nDial *98 to access
your voicemail by phone.\nVisit http://pbxxxx.xxxx.local/recordings/index.php to check your voicemail with a web

You have

include vm_email.inc
include vm_general.inc
4980 => 8376,Mark xxxx,[email protected],,attach=yes|saycid=no|envelope=yes|delete=no

It should be:

#include vm_email.inc
#include vm_general.inc
4980 => 8376,Mark xxxx,[email protected],,attach=yes|saycid=no|envelope=yes|delete=no

Notice the added ‘#’ in front of include

Interesting… is # not for comments in this file? I’ve tried it both ways, but honestly I kept changing it out of frustration and lost track of what worked and what didn’t and if I reloaded or not.

I’ll give it a go… makes sense.


I think that after making modifications you need to reload the voicemail module to read in the changes. Type module reload app_voicemail.so in asterisk cli