Voicemail to e-mail and ARI playback not working


I have two voicemail issues. I have put them both in this thread as they could somehow be related. I know it’s poor form :frowning:

Thanks for your time everyone.

Version info:
FreePBX 2.6.0.RC1.1 - everything updated to lat
Voicemail Module
ARI Framework
CentOS 5.3 2.6.18-128.7.1.el5 x86_64

These symptoms were exhibited under 2.5, I thought the upgrade to 2.6-beta might squash these problems. It did not.

Problem 1: voicemail to e-mail not working properly

/etc/asterisk/voicemail.conf had the following commented

#include vm_general.inc
#include vm_email.inc

I uncommented it and things did not change

Further down here is an example line:
333 => 333,User,[email protected],attach=yes|saycid=no|envelope=no|delete=no


emailbody=${VM_NAME},\n\nThere is a new voicemail in mailbox ${VM_MAILBOX}:\n\n\tFrom:\t${VM_CALLERID}\n\tLength:\t${VM_DUR} seconds\n\tDate:\t${VM_DATE}\n\nDial *98 to access your voicemail by phone.\nVisit http://AMPWEBADDRESS/recordings/index.php to check your voicemail with a web browser.\n

It could be a system issue, perhaps. I do get the FreePBX updates e-mails, but maybe the voicemail to email system uses a different mailing method.

Thoughts? Where ought I begin debugging?

Problem 2: the ARI interface doesn’t do anything useful.

This behavior has been reproduced on Windows and OS X in Firefox, and IE and Safari.

The playback options don’t do anything.

The voicemail will not play in the browser
The voicemail will not play back to the phone when initiated from the browser, the browser says "The call failed. Perhaps the line was busy."
The voicemail will not download. It gives a 404: “404 File not found!”

I see the wav file in /var/spool/asterisk for the extension. The directory is 770 asterisk:asterisk and apache runs as asterisk…

Once again, any thoughts on how to track this issue down would be appreciated.

  1. Do NOT remove the ‘#’ from voicemail.conf, they are there for a reason.

  2. Check your /var/log/maillog for any errors relating to the file not mailed to you.

  3. Don’t know

Ahh… yes… i had a silly typo in my postfix config…

Thanks :slight_smile:

but the ARI issues remain.

Alrighty. The problem was found in /var/log/httpd/error_log

Since I had apache running as the asterisk user it couldn’t read/write to /var/lib/php/session which futzed up ARI

The fix was a simple chown and and I’m in business.