Voicemail timezone issue

I have an issue with voicemail times. In this instance, the time on the server is set to GMT, but I am in Eastern time. I’m unclear how I can alter the voicemail time to reflect the eastern time through the GUI. I don’t find any examples, and all of the searching I have done shows the similar question, but no answers outside of changing configuration files in asterisk which I am not comfortable doing. Any help or am I stuck?

Probably a Catch-22 here, you can add tz=eastern as a vm option in the extension but that needs to be resolved in voicemail.conf to an entry in the [zonemessages] stanza which to my knowledge is not doable in the gooey , it’s quite easy though , the example in the source code is :-

; Users may be located in different timezones, or may have different
; message announcements for their introductory message when they enter
; the voicemail system. Set the message and the timezone each user
; hears here. Set the user into one of these zones with the tz= attribute
; in the options field of the mailbox. Of course, language substitution
; still applies here so you may have several directory trees that have
; alternate language choices.
; Look in /usr/share/zoneinfo/ for names of timezones.
; Look at the manual page for strftime for a quick tutorial on how the
; variable substitution is done on the values below.
; Supported values:
; 'filename'    filename of a soundfile (single ticks around the filename
;               required)
; ${VAR}        variable substitution
; A or a        Day of week (Saturday, Sunday, ...)
; B or b or h   Month name (January, February, ...)
; d or e        numeric day of month (first, second, ..., thirty-first)
; Y             Year
; I or l        Hour, 12 hour clock
; H             Hour, 24 hour clock (single digit hours preceded by "oh")
; k             Hour, 24 hour clock (single digit hours NOT preceded by "oh")
; M             Minute, with 00 pronounced as "o'clock"
; N             Minute, with 00 pronounced as "hundred" (US military time)
; P or p        AM or PM
; Q             "today", "yesterday" or ABdY
;               (*note: not standard strftime value)
; q             "" (for today), "yesterday", weekday, or ABdY
;               (*note: not standard strftime value)
; R             24 hour time, including minute

eastern=America/New_York|'vm-received' Q 'digits/at' IMp
central=America/Chicago|'vm-received' Q 'digits/at' IMp
central24=America/Chicago|'vm-received' q 'digits/at' H N 'hours'
military=Zulu|'vm-received' q 'digits/at' H N 'hours' 'phonetic/z_p'
european=Europe/Copenhagen|'vm-received' a d b 'digits/at' HM

so add that to /etc/asterisk/voicemail.conf and tz=eastern to extensions in above, add other ‘zonemessage’ enjtries as appropriate for your extension in Denver or the Yucatan

Is there no place in the GUI in freepbx to edit/alter this setting?

I don’t believe so. But I have been wrong before :slight_smile:

If you have the “distro” sysadmin allows you to globally set your system TimeZone but that would be global for all voicemail users. If you don’t have that then you would need to do that with timedatectl and make sure your php.ini(s) is also copacetic

I put that in there and this is the email I get

There is a new voicemail in mailbox 2012:

From:	"2012" <2012>
Length:	0:05 seconds
Date:	Friday, April 22, 2022 at 08:27:49 PM

4 hours ahead

That will only work if you have a resolvable entry in [zonemessages] matching ‘eastern’ (and your system time would best be also set to to America/New_York or more generically America/Eastern)
Any changes to voicemail.conf also need either 'voicemail reload` or a fwconsole restart/reload


But . . The email text is likely using your system time , apparently still UTC, what does typing date return from a shell ?
The audio heard by the subscriber when retrieving their message should however reflect any zonemessage setting you implement

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.