Voicemail set for deletion but message still being kept


(Zurd) #1

Hi, I configured an extension with an Email Address and “Delete Voicemail” to Yes. When someone call the phone and leave a message, it is being sent to this user email address but the messages is still on the server. I can see it in /var/spool/asterisk/voicemail/default/EXT/INBOX and I can also see the total number of messages in Settings / Voicemail Admin in the dashboard.

I see nothing special in the log. Why would that be?


(Itzik) #2

Does it send you a MWI notification as well?


(Zurd) #3

MWI? How can I check?


(Itzik) #4

Please reply with the following:


(Zurd) #5

I did a call trace but there is absolutely nothing useful in it, the user leaves a message, everything is working fine and there is no information, no error message about the voicemail being deleted or not. FreePBX just does not delete the message even though it is configured to do so.

I thought someone knew of a specific setting that would make this problem, there’s probably something easy as a solution. I doubt it’s permission, everything in /var/spool/asterisk is owned by asterisk:asterisk

Don’t have much time to waste on this, I will just set the maximum messages of voicemail to 9999 in Settings / Voicemail Admin / Settings / Limits. They dont take much space and we have plenty. They should be good forever now.


(TheJames) #6

AHHHHHHHH The beautiful world of open source.


(Simon Telephonics) #7


(Zurd) #8

Like I said, this is already configured to Yes.


(Simon Telephonics) #9

I am putting the solution there for others that find the thread.

We don’t know why it doesn’t work for you because you are not troubleshooting the issue.

But that setting works for me.


#10

Given the lack of information, was the extension’s submit button hit and FPBX reloaded?


(Simon Telephonics) #11

The authoritative answer is going to be in /etc/asterisk/voicemail.conf where the entry for the mailbox should have “delete=yes” in the string of options.


(Zurd) #12

cat /etc/asterisk/voicemail.conf
302=5163,USER,EMAIL,attach=yes|saycid=yes|envelope=no|delete=yes

So everything is fine in this file.

However, nielsen hit it right, I did a systemctl restart asterisk and now it’s working like it should, problem solved! I knew the solution was easy, I was just too dumb to figure it out alone :wink:


(Jared Busch) #13

No, that is something you should never do. Not that you cannot but if you’re using free PBX that is not the designed way to control the system


(system) closed #14

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.