Voicemail saves to /tmp but not /INBOX

Im on

When im recording a voicemail, i see it saves in exten/tmp
the .txt file and the .wav file

When I press 1 to accept, it dissapears out of exten/tmp
I look in exten/INBOX
and it is empty in there

The cli says:
Parsing ‘/var/spool/asterisk/voicemail/default/1234/INBOX/msg0000.txt’: Found
Parsing ‘/var/spool/asterisk/voicemail/default/1234/INBOX/msg0000.wav’: Found

But its not there.

(i can select to email as attachment, and i get it in the email just fine)

There was a problem a while back, but I thought it was solved that caused behavior similar to what you describe.

I believe that has been solved, but you never know.

A description of the earlier problem can be found here:



I guess asterisk was compiled with ODBC_Storage enabled for voicemail.
I just want to use the default text file method.
I did this to fix:

/etc/init.d/asterisk stop
make clean
make menuselect / Voicemail Build Options / ODBC_STORAGE -Turn Off
make install
cd /asterisk-addons
make install
/etc/init.d/asterisk start