Voicemail problem


#1

Using FreePBX 13.0.197.22

I just created a new extension with voicemail.

The user has recorded their greeting messages.

Everything seems fine.

However, then user is not getting their voicemails !

Trying to troubleshoot: when calling this extension and ending up on the voicemail, we hear the recorded greeting, we can leave a message. If we press a key to get options, and you select send the message, then the system responds with “an error has occurred” en hangs up.

I don’t know where to look to find logs or more info on what’s going on.

Any idea?


(Communication Technologies) #2

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug


#3

Well that was great help.

I fired up the console using tail -f /var/log/asterisk/full

Then I tried to reproduce the error and saw this:

[2020-08-03 17:49:47] VERBOSE[4602][C-0003137e] app_voicemail.c: Recording was 2 seconds long but needs to be at least 5 - abandoning

Apparently all the tests we made were less that 5 seconds long and therefore failed !!!

Problem “solved”, thank you @comtech !!


(Dave Burgess) #4

Remember, you can adjust that minimum in the Advanced Settings (IIRC), but seriously, if someone is going to leave a meaningful message, it’s going to last more than 15 words.


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.