Voicemail not working

Hi everyone,

I’m running Asterisk with FreePBX on a CentOS Amazon instance. The installation process I followed was installing Asterisk from source and FreePBX on top of it.

It works great except voicemail is not working. When I go to Settings > Voicemail admin I see: 33 ( 0 / 1 / 32 ), which represents the total number of accounts (Actived/Unactived/Disabled). First, I tried finding an option to “activate” the voicemail but it seems that is not a configuration problem but a module problem.

So, after googling I tried: module load app_voicemail.so at the Asterisk CLI and the result is:

Command ‘module load app_voicemail.so’ failed.

[2012-07-06 13:32:19] WARNING[12490]: loader.c:779 inspect_module: Module ‘app_voicemail.so’ was not compiled with the same compile-time options as this version of Asterisk.

[2012-07-06 13:32:19] WARNING[12490]: loader.c:780 inspect_module: Module ‘app_voicemail.so’ will not be initialized as it may cause instability.

[2012-07-06 13:32:19] WARNING[12490]: loader.c:863 load_resource: Module ‘app_voicemail.so’ could not be loaded.

I tried different options to solve this but none of them worked for me. Why is this? I mean, everything is working fine but the voicemail. I tried to installing it via yum but same issue.

Any hint?

Thank you very much!

This is one of the problems you have when you try to “Roll Your Own”. If you want a Stable, easy to install system, download and install one of the distros, either the “Official” FreePBX distro which is available, or PBX in a Flash, by Ward Mundy et al.

Both will do the job with excellent results.

Problem is that you may be the only user in the whole world with a setup that exactly matches yours. With one of the distros there are literally of thousands of users out there to help.


That’s true; probably my set doesn’t exactly match any other but I don’t see that these differences cause much trouble. I was hopping that, although not running the same system, someone had similar problem or at least knowing where to start from.

The thing is that I don’t see why this is happening since Asterisk was compiled without freePBX touching it. I first installed Asterisk and FreePBX afterwards.

Anyway, I don’t have the possibility of installing an out-of-the-box distro. They come with the operating system and since I’m running an AWS instance you cannot install it.

So, what options do I have? I think the best way of fixing this is taking care of the issue itself instead of turning around as I said there is little flexibility when working with Amazon AMIs.

Thanks a lot.

The question really comes down to how you installed Asterisk.

Did you use the Digium RPM? That should be OK?

I would think you would be better off downloading the source and building from scratch.

Somehow the version of Asterisk you are running does not match the module you are trying to load.

FreePBX does not load any Asterisk modules or software.

Thanks for the replies. I recompiled and installed Asterisk from source. Before this I had to remove all modules under /usr/lib/asterisk/modules/.

After this I reinstalled FreePBX from source and it went ok. The problem is that now it seems that FreePBX is not writing any .conf files. Under /etc/asterisk/ there are all .conf files (additional, custom, etc.) but the main files (i.e. sip.conf, extensions.conf) are not being created by FreePBX. Instead, they are the samples coming with Asterisk.

Any ideas on how I can solve this?

Thanks in advance.

I think it might be important to note that I had an error on the system status page. It says:

Symlink from modules failed
Ignore this
retrieve_conf failed to sym link:
/etc/asterisk/ccss.conf from campon/etc (Already exists, not a link)
/etc/asterisk/extensions.conf from core/etc (Already exists, not a link)
/etc/asterisk/sip_notify.conf from core/etc (Already exists, not a link)
/etc/asterisk/features.conf from core/etc (Already exists, not a link)
/etc/asterisk/logger.conf from core/etc (Already exists, not a link)
/etc/asterisk/iax.conf from core/etc (Already exists, not a link)
/etc/asterisk/sip.conf from core/etc (Already exists, not a link)

This can result in FATAL failures to your PBX. If the target file exists and not identical, the symlink will not occur and you should rename the target file to allow the automatic sym link to occur and remove this error, unless this is an intentional customization.

Added 10 minutes ago

I guess that it can have relation with the problem of writing the files. The thing is that I have a previous version of the whole installation that launches the same error but everything works more or less (it has the voicemail problem).

Ok. The problem has been solved.
After recompiling Asterisk everything went fine.