Voicemail not playing from Aastra XML Script

I am not able to get voicemail to play through the Aastra vmail script. The voicemails are there and will play with *97, but not through the script.
/var/log/asterisk/full says:
[Oct 24 13:15:27] WARNING[6168] file.c: File /var/spool/asterisk/voicemail/default/301/Old/msg0000|2000|6|4|0|5|1 does not exist in any format
[Oct 24 13:15:27] WARNING[6168] file.c: Unable to open /var/spool/asterisk/voicemail/default/301/Old/msg0000|2000|6|4|0|5|1 (format 0x280004 (ulaw|h263|h264)): No such file or directory

However the directory shows:
[xxx.xxx.xxx log]# ls -l /var/spool/asterisk/voicemail/default/301/Old/
total 52
-rw------- 1 asterisk asterisk 20889 Oct 24 13:15 msg0000.gsm
-rw------- 1 asterisk asterisk 269 Oct 24 13:15 msg0000.txt
-rw------- 1 asterisk asterisk 20600 Oct 24 13:15 msg0000.WAV

I am quite baffled at this point. Please help.
Running asterisk 1.6

Not sure if it would make a difference, but did you try to change permissions? Let’s say 775 or 777 as a test on those 3 files?

Are messages in other mailboxes the same 600 permission format?

Yeah I tried changing perms. I have messed with other things since though, so I will try that again.

Ok, set the perms to 777 and still the same result.

I forgot it needed that patch available at: