Voicemail not finding wav files

Hi All,

Hopefully someone can help me out here. I’ve just upgraded to FreePBX 2.6.0.beta2.0 and since the upgrade, voicemail isn’t working correctly.

I can dial in to listen to messages etc but if a call goes to voicemail it just drops the call.

The log file shows the following.

[Aug 28 15:47:31] DEBUG[3439] app_macro.c: Executed application: Answer
[Aug 28 15:47:31] VERBOSE[3439] logger.c: – Executing [[email protected]:18] Read(“SIP/201-08416920”, “ACTION|/var/spool/asterisk/voicemail/default/212/unavail|1|skip|1|2”) in new stack
[Aug 28 15:47:31] VERBOSE[3439] logger.c: – Accepting a maximum of 1 digits.
[Aug 28 15:47:31] WARNING[3439] file.c: File /var/spool/asterisk/voicemail/default/212/unavail does not exist in any format
[Aug 28 15:47:31] WARNING[3439] file.c: Unable to open /var/spool/asterisk/voicemail/default/212/unavail (format 0x4 (ulaw)): No such file or directory
[Aug 28 15:47:31] VERBOSE[3439] logger.c: – User disconnected
[Aug 28 15:47:31] VERBOSE[3439] logger.c: == Spawn extension (macro-vm, vmx, 18) exited non-zero on ‘SIP/201-08416920’ in macro ‘vm’

I’ve looked in /var/spool/asterisk/voicemail/default/212/ and there is an unavail directory (which is empty as there hasn’t been a recorded custom message) and I’m not sure if this is correct.

I have just tried a user that has a recorded custom message and that just palys the default message…but is at least working.

Any advice would be very gratefully received.

Thanks.

Dave.

it does not sound like something that should be related t the upgrade. What version of Asterisk are you running?

Hi Philippe,

Thanks for your reply.

I’m running 1.4.16.2

Thanks for any help you can provide.

Regards,

Dave.

Do you have the Asterisk SIP Settings module installed? If you have that, please do a Check for updates online and update all modules that have updates.

Check your sip_general_additional.conf and verify that you have at least the follwoing:

disallow=all
allow=ulaw
allow=alaw
allow=gsm

Hi,

I do have this module installed, I have just checked for updates and everything is current.

In the sip_general_additional.conf file (in /etc/asterisk) I do have these options, below is a copy.

Thanks again for your help with this.

Regards,

Dave.

;--------------------------------------------------------------------------------;
; Do NOT edit this file as it is auto-generated by FreePBX. All modifications to ;
; this file must be done via the web gui. There are alternative files to make ;
; custom modifications, details at: http://freepbx.org/configuration_files ;
;--------------------------------------------------------------------------------;
;

vmexten=*97
context=from-sip-external
callerid=Unknown
notifyringing=yes
notifyhold=yes
limitonpeers=yes
tos_sip=cs3
tos_audio=ef
tos_video=af41
alwaysauthreject=yes
disallow=all
allow=ulaw
allow=alaw
allow=gsm