Voicemail not delivered

I have new install 64-bit stable running since Monday. All of a sudden voicemail is no be delivered. In the CLI I see the temp recording, but after disconnect it deleted and is not in the INBOX for the extension dialed.

Deleted and recreated the extension. Disabled and re-enabled voicemail on the extension. No joy.

Thanks for any help

– Executing [[email protected]:2] VoiceMail(“SIP/204-00000030”, “[email protected],u”"") in new stack
– <SIP/204-00000030> Playing ‘vm-theperson.ulaw’ (language ‘en’)
– <SIP/204-00000030> Playing ‘digits/2.ulaw’ (language ‘en’)
– <SIP/204-00000030> Playing ‘digits/0.ulaw’ (language ‘en’)
– <SIP/204-00000030> Playing ‘digits/1.ulaw’ (language ‘en’)
– <SIP/204-00000030> Playing ‘vm-isunavail.ulaw’ (language ‘en’)
– <SIP/204-00000030> Playing ‘vm-intro.ulaw’ (language ‘en’)
– <SIP/204-00000030> Playing ‘beep.ulaw’ (language ‘en’)
– Recording the message
– x=0, open writing: /var/spool/asterisk/voicemail/default/201/tmp/1G01pi format: wav, 0x122d6a48
– User hung up
== Spawn extension (macro-vm, s-NOANSWER, 2) exited non-zero on ‘SIP/204-00000030’ in macro ‘vm’
== Spawn extension (macro-exten-vm, s, 21) exited non-zero on ‘SIP/204-00000030’ in macro ‘exten-vm’
== Spawn extension (from-internal, 201, 2) exited non-zero on ‘SIP/204-00000030’
– Executing [[email protected]:1] Hangup(“SIP/204-00000030”, “”) in new stack
== Spawn extension (from-internal, h, 1) exited non-zero on 'SIP/204-00000030’
pbx*CLI>

Hi,

Its probably a permissions error on the folders storing the voicemail. Check what the voicemail path is in /etc/amportal.conf and then make sure the owner of that path is asterisk:asterisk

Would help if I knew which distro you was using.

Best Regards,

Matthew