VoiceMail Light not lighting on phones

hi, i have a new install of, with some grandstream phones. the voicemail light is not lighting. I have been searching a lot and stumbled across this:
which indicates that the mailbox has to agree with the section heading in voicemail.conf.

so when I look at my pjsip.aor.conf file, i see my extensions like this:

[email protected]

but when i look at my voicemail.conf, the section looks like this:

5028 => 1111,person,[email protected],attach=no|saycid=no|envelope=no|delete=no

note that voicemail section header is default, while the mailbox is @device…so, am I right in thinking this is a problem…if so, why is it like this? I do not edit these files, I only make changes in the gui?

thanks for your help

I do not know about the grandstream phones, but the Yealink phones have a setting for this.

Use account.x.subscribe_mwi = 1 to have the phone solicit for MWI (which is the default for PJSIP in FreePBX 13).

Apparently with chan_sip it would try both or something. I’m not clear on that, but with chan_pjsip it only works as specified.

If you would consider using the commercial EPM it will create the config files for you with message waiting working right out of the box. :wink:

This issue is caused by a difference in chan_pjsip vs chan_sip.

Telling people that the answer is to buy something is not a great way to earn respect.

Interesting that you took it that way. The only reason I suggested that is because I was thinking that you were having problems programming the phone and the epm makes it pretty fool proof.
I am very well respected amongst my peers with 32 years of experience in the industry, but I cannot please everyone I guess.

1 Like

I am sorry I did not mention it, but I am in fact using Commercial EPM. I have found that there is much that Commercial EPM does not handle. I am looking into the mwi setting on my grandstream phone. i will report back my findings.


thanks for pointing me in this direction, there is a similar setting for grandstream phones, i am investigating now, and will let everyone know.