Voicemail issue, not consistent with settings

Having a sudden problem with voicemail. Basically any voicemail of less than 10 seconds isn’t kept. if the user hangs up, they have no clue, but if you hit “#”, you get the Allison “I’m sorry an error has occurred”. The output in the CLI is:
– Recording was 3 seconds long but needs to be at least 6 - abandoning
– Executing [[email protected]:3] Goto(“SIP/TrunkToATT2-00000fab”, “exit-FAILED,1”) in new stack
– Goto (macro-vm,exit-FAILED,1)
– Executing [[email protected]:1] Playback(“SIP/TrunkToATT2-00000fab”, “im-sorry&an-error-has-occurred”) in new stack
– <SIP/TrunkToATT2-00000fab> Playing ‘im-sorry.ulaw’ (language ‘en’)
– <SIP/TrunkToATT2-00000fab> Playing ‘an-error-has-occurred.ulaw’ (language ‘en’)

But, we have seen the same “Recording was 3 seconds” even if you talk/record for up to 20 seconds.
I have changed the minimum in the GUi to 3 seconds, but the CLI still thinks the minimum is 6. Even so, sometimes a 15 second message will still drop and show as “only 3 seconds”.

Trying to change any settings in “settings/voicemail settings/settings tab/limits” results in a nasty screen.

Let me know what details will help from that screen, but the main error is
Whoops \ Exception \ ErrorException (E_WARNING)
chown(): Operation not permitted

Using a fully patched out of the box FreePBX distro that has been running fine for a few months. Thoughts on what is corrupted, and/or how I can fix it?
PBX Firmware: 10.13.66-17
PBX Service Pack:

fwconsole chown

Thanks. Sorry, forgot to include I had already done that. It didn’t fix that error. Interestingly enough the old amportal chown (which I thought just ran fwconsole chown anyway) actually fixed the error.

But the voicemail issue persists. I was now able to set the minimum message length to 2 seconds, which now will allow a message of 5 actual seconds or less to work properly. Not really a fix, but its a workaround.

Still think there might have been a bug in a recent update that caused this all of a sudden…

Thanks for the reply.

Wouldn’t this be an issue with Asterisk? You can check the voicemail.conf file yourself. /etc/asterisk/voicemail.conf

Yes. The voicemail.conf matches the FreePBX GUI - my min seconds is now 2 seconds so messages of 4-5 seconds are now saved. Setting it to 5 seconds means you have to leave a 10+second message for it to stick.

Anyway - I suppose Ill just wait and see if there is an update later that changes this.

I was posting here because I was using the FreePBX distro out of the box, so I was concerned about the anomaly

Sorry forgive me but I do not know what you are expecting to change. Everything seems to be correct. What do you think should be updated?

The problem I am seeing is thst I had to reduce the minsecs to 2 in order to get a voicemail of 5 seconds to actually save. If I set minsecs to 6 (default) a 10+ second message wont save and in the CLI it says the message is only 3 seonds long. No matter what size voicemail you leave, the system seems to think its only 3 seconds - yet when you get the voicemail attachment, it has the correct time length in the description.

Thanks - either way, I have a workaround - however, since silence is still set at 5 seconds, I may get some empty messages, but Ill deal with that if it happens.

Do you have talk detection (or silence detection) enabled? It doesn’t work well imo, and can make asterisk think your vm’s are shorter than they are.

Sorry, I’m not sure, where re those settings? I haven’t really changed anything from default, but let me know where I can check/disable that. My voicemail settings are below.