Voicemail ImapStorage Not Working in FreePBX 2.10


I have a freshly installed FreePBX system where IMAP storage is not working. I have done the following:

yum remove asterisk18-voicemail
yum install asterisk18-voicemail-imapstorage

and confirmed when I run cat /var/log/asterisk/full I can see the system loading app_voicemail_imapstorage.so properly. I also noticed, however that app_minivm.so was being loaded. Not sure why. I also know that the 3 other systems I recently installed work fine from doing the above steps (also after configuring voicemail admin settings for our hosted IMAP server’s specifications. However, with this new install (newer distro download, perhaps?) it will not send voicemail to IMAP. It continues to be held at /var/spool/asterisk/voicemail…

I also know that if I check the ARI, I can see the voicemail messages for a given extension, and I know that this should not be possible when using our hosted IMAP server in the cloud.

Any suggestions?



Here are the versions:


I can confirm in the logs when I reboot Asterisk that the module is being loaded:

I can also confirm that when I Putty to our system and type module show like app_voicemail

only 1 item is displayed:

Module Description Use Count app_voicemail_imapstorage.so Comedian Mail (Voicemail System) 0 1 modules loaded

I checked with our other systems that are running on Asterisk 1.8.8 and when I type module show like app_voicemail

The description there says:

I’m guessing it is saying with IMAP, but was truncated. So it appears to me that package

Asterisk18-voicemail-imapstorage in the reposity says it is the app_voicemail_imapstorage.so module, but instead is app_voicemail.so.

I have all our IMAP fields filled in, but voicemail is being stored locally under /var/spool/asterisk/voicemail/ instead.

I also tried downgrading to any older version for but it would not downgrade to the prior version that works for

Hoping this is something simple that can be fixed asap.

I created a ticket now at


Not sure if this has any bearing, but when I dial *115 to call voicemail direct for ext 115, it says “phone 115 is currently unavailable. goodbye.”

Again, I am still using the app_voicemail_imapstorage module. I can still leave messages by dialing an extension and letting it go to the mailbox, but it is still at /var/lib/spool/asterisk/default

I am under the impression that for FreePBX 2.10 you will need to do this:

yum remove asterisk10-voicemail
yum install asterisk10-voicemail-imapstorage.i686