Voicemail Greetings

Hello Hello,
So the version is 6.12.65-18.
My setup is like:
Caller comes in,
Send to IVR or IVR after hours,
IVR after hours = Play custom message, wait for timeout, send to IVR voicemail,
IVR voicemail = Play custom message, wait for timeout, send to dedicated voicemail extension who is never logged in so is always unavailable.

Would like to not play unavailable message and just get to the beeeep.
Please help.

Thank You,

When you chose the Voicemail box for your IVR timeout destination, did you choose the “unavail” or the “no-msg” option?

The final destination is an extension that is there only to receive all voicemails.

Are you asking how the extension is setup?
Or, are you asking how the IVR that sends call to the vm ext. is setup?

Sorry if I am confusing you.


In the final IVR. I didn’t say send to voicemail then select extension number. I said send to Extension and then selected the that vm ext.

I see the unavail and no-msg now when I first select send to voicemail.

I’m not out of the woods yet but am getting closer with a little help from my new friends. Thank you ! Thank you ! Thank you !

Maybe your confusion yourself,

In the IVR Timeout extension choice you had the option of sending to a voicemail box(no-msg), that would have given you what you ask for, maybe you didn’t think that was necessary either.

Just spend some time with the Wiki here, it works for most everyone else.

Ok. so there is this long weird silence.
After the IVR message stops, wait for timeout, send to voicemail - instructions only.
I have timeout set to zero, I have tried -100, -1000, -5000. Nothing is making the silence between the end of the IVR message and the beginning of the vm-instructions any shorter.

How can this be achieved?

Thank You.

There is no silence at the end of the recording. To get to negative timeout I just kept clicking the down arrow on the .js menu. I didn’t click it 5000 times, hold down or enter the value manually… =0)

So I have never actually tried 1 second. I went for zero right off the bat. Using 1 or 2 is perfect! … imagine that.
Thanks again.

Trim the silence from the end of your IVR message if necessary and a reasonable timeout would be 5 (seconds), was using negative values a guess ?, again I suggest you browse the wiki before you try to do anything else, especially if that involves you assuming or guessing :slight_smile:

1 or even 2 second is not enough for “normal selections” in the IVR. Again, please RTFM(S)