Voicemail email not working FreePBX and Zimbra on same box

Hello all,

I would like your advise on a situation where voicemail email is not working.
We are running FreePBX manually installed on CentOS 6.5. On the same box Zimbra Community server is running. Zimbra as well as FreePBX are running fine, so no installation issues.

Problem is, that voicemail emails don’t go anywhere.
Zimbra and FreePBX are bound to separate private IP addresses, but Postfix (which is also being used by Zimbra) responds to all IP addresses.
SELinux is completely disabled.
Zimbra allows relay from the private /24 network, including the IP
Zmbra mail log does not show any signs of mail coming from Asterisk.

As far as I understood, Asterisk directly addresses Postfix, not using a IP address. I am not sure if Postfix refuses Asterisk to send mail because of Zimbra-specific configuration. I don’t want to mess around with the Postfix config and risking to break Zimbra.

Can anyone give me some advise? for instance: is it possible to instruct FreePBX to address Postfix using IP instead of directly?

Thanks in advance.

Asterisk doesn’t actually use email, comedian mail which is the normal voicemail subsystem has a couple of variables set in /etc/asterisk/voicemail.conf or it’s includes mailcmd and externnotify which you can change to suit your quirks ref:-


the default for mailcmd is covered by postfix’ compatability interface, the externnotify can be anything that asterisk can read and use.

Dicko, Thanks for your reply.

My /etc/asterisk/voicemail.conf is almost empty.
None of the options from the support article are there.
Is it safe to manually add the options I want? I suppose FreePBX will override the file when changes are made from the webinterface.

This is my voicemail.conf:

#include vm_general.inc --> commented out, but the forum removes the hashtag
#include vm_email.inc --> commented out, but the forum removes the hashtag

Extensions and their settings from here.

You are probably safer using the GUI, generally at:-


depending on how you set up your box.

be careful in reading files here in asterisk, comments are generally prefaced by ; , included files by #


Thanks for your help, I got it working.

Within FreePBX Voicemail admin you need to enter as mailcmd '/opt/zimbra/postfix/sbin/sendmail -t’
Now it’s working.
Thanks again!

Glad you got it working but technically that should be “I needed to enter . . .” or more generically add the non standard /opt/zimbra bits to your asterisk user’s path or perhaps other things might not work either :slight_smile:

Hi Dicko,

Thanks for your English 101 class :wink:
Of course you’re absolutely right.
We Dutch have a nasty habit: we tend to talk about ‘you’ when we mean ‘I’.
Soccer players are champions. The famous Johan Cruijff has completely banned ‘I’ from his vocabulary.