Voicemail email 'from' address. ripping my hair out

Errors in debug:
(actual domain replaced by ‘fakedomain’)

Feb 2 20:11:21 freepbx postfix/qmgr[1400]: 76917C36B495: from=**asterisk**@fakedomain.com, size=797, nrcpt=1 (queue active)
Feb 2 20:11:22 freepbx postfix/smtp[5249]: 76917C36B495: to=[email protected], relay=10.78.1.253[10.78.1.253]:587, delay=0.56, delays=0.17/0.18/0.18/0.04, dsn=5.7.1, status=bounced (host 10.78.1.253[10.78.1.253] said: 550 5.7.1 Client does not have permissions to send as this sender (in reply to end of DATA command))
Feb 2 20:11:22 freepbx postfix/cleanup[5236]: 15CABC36B49A: message-id=[email protected]

Generic file:

root [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]
asterisk [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]
[email protected] [email protected]

I have the from address correct in the Voicemail module and am rewriting [email protected] to the correct smtp address in postfix generic. Have done a postmap /etc/postfix/generic, reloaded, postfix, restarted postfix, and even rebooted the box. It’s still sending as [email protected]

I cannot figure out why. It’s causing the emails to bounce.

Any ideas?

So if the system is not using the SMTP address specified in the Voicemail module to send voicemail emails, is that considered a bug? I really want this fixed and really don’t want to buy support credits or engage in another debate about what constitutes a bug.

Did you buy the System-Admin module for 25$? There you can easily configure your email settings…

Have you configured the other items in postfix? relayhost, sasl_passwd?

Yes. What I’m saying is that what’s set in the GUI is not what’s being done by the software.

I was able to rewrite the domain (though this should not have to be done), but not the part before the @. I had to add [email protected] as a valid SMTP address for the account being used to send voicemails.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.