VoiceMail BLF not working properly

Hello Experts :slightly_smiling:
I’ve setup a virtual ext. with voicemail.
I’ve registered a blf key for that Voicemail (*98390):
*[email protected] : MWI:[email protected] State:Idle Presence:not_set Watchers 6
on other posts I saw that MWI:[email protected],
I wonder if that is my problem .
If I reboot the blf turns on as expected but next messages wouldn’t register and turn the BLF on upon new message.
side node : upon receiving new vm I get an email as expected / configured .

would appreciate any input.

Thank you.

We are having the same issue.

Your BLF has to match the one of your hints.

Use ‘asterisk -vr’ and issue “core show hints” to see what hints are active. I think you are going to find the default context part is what you need, but the hints will tell you for sure.

Make sure you are running the latest version of asterisk in the 11 or 13 branch. Earlier versions have known BLF issues.

info page says :
Current Asterisk Version: 13.5.0
this comes and goes , not sure even why today we have 5 vms in our mailbox and the hint is as follows :
*[email protected] : MWI:[email protected] State:Idle Presence:not_set Watchers 6

Upgrade Asterisk to current, 13.7.

I’ll try that .
Thanks .

I’m on
Current Asterisk Version: 13.7.2

works fine after restart as I mentioned before but then after a while it’s not working again.
and again I see that hints are without the @Default
e.g
*[email protected] : MWI:[email protected] State:Idle Presence:not_set Watchers 1

What version of the FreePBX Distro are you using as this feature only works on FreePBX Distro

Hi Tony .
I’m using the 13 Distro .
I’ve tried to remove the commercial voicemail notification thinking maybe it might have something to do with this. so far it’s working but it’s too soon to tell since it’s only been a couple of hours.

also after running
core reload
I see that the hint values are updated properly e.g. MWI:[email protected] vs MWI:EXT
but I have to restart my phone for the blf to reflect the changes.also restarting the phone without the core reload has no effect.
Thanks !

feels like it’s working ok now .
I’ll try to reinstall voicemail notification again this weekend and report back .

lasted longer than usual but today it failed again :

*[email protected] : MWI:[email protected] State:InUse Presence:not_set Watchers 1

so currently the BLF is off whilst I have a VM waiting.

Did you ever find a resolution to this?

I just attempted to set this up and I am having the same issue.

PBX Firmware: 10.13.66-11
PBX Service Pack: 1.0.0.0
Current Asterisk Version: 13.7.2

Have you seen this ticket:
http://issues.freepbx.org/browse/FREEPBX-11223

Thanks friend. I will check out the edge track for those modules and see if it resolves my issues.

1 Like

Well it appeared to have fixed the issues in testing environment, but when I pushed it to a production server, it worked for a bit and then reverted back to the old behavior.

I updated the ticket with my comments.