Voicemail attachment sent from FreePBX User Portal being sent as .txt file

When I select a voicemail from the FreePBX User Portal and choose the email_to button, the email that is received has a .txt attachment not the .wav file. If I select 2 voicemails then I get one .txt and one .wav file. If I choose more than 2 then I get one .txt and several copies of the same .wav file with different filenames and sizes but the same voicemal message.

The odd part is that email notifications sent directly from asterisk have the correct attachment.

Another thing that I noticed is that the emails sent from asterisk come from a different email address than the ones forwarded from the user portal…Essentially, the FreePBX UserPortal is ignoring the settings from vm_general.inc.

Any thoughts?



I am experiencing the same thing and having a heck of a time searching this forum for an answer.

Did you happen to figure this out? I have the same situation.


Is there anyone out there with a resolution? Same issue using a fresh install of AsteriskNOW 1.7 upgraded to FreePBX 2.8


Please file a ticket about this so it will be looked into. It sound like a bug to me. And it is in ARI not in the Voicemail module.

I also need a complete mail with the symptom, including all the headers. If you can provide that to me it would certainly help a lot.

What kind of distro are you using?

Please PM me so I can provide an email address where you can forward the mail to me.


Did you ever get an answer? I’m having the same problem. I looked at your ticket. I think this is the first time I have ever sent from the ARI. I have them set to auto email but that stopped suddenly. Thats another thread but I will say that my system stopped sending the wav attachments because its getting an invalid sender domain. I didn’t change anything. I tried sending via ARI and the message is sent, but with the same results you have. The attachment is a txt rather than wav.

Have you tried another browser? Has your email admin changed anything?


I use Firefox and hadn’t thought to try another. I tried microsoft explorer with same result. I am the admin so I make all the changes. Running Freepbx 2.8 with Asterisk About a month ago it quit mailing voicemail to the configured addresses of the users so I forwarded one from the ARI. That was sent (or received) as a txt file. I see that that is a fairly frequent result but seems that there are no answers. The only thing I notice is that seems like the developers become defensive when it is questioned, being quick to reply that it is not a bug on their end. I just thought about restoring to a backup when messages were being emailed properly. I’ll have to do that on the weekend though. That won’t tell me what is causing it, but it will tell if it is an Asterisk update or Freepbx update that broke it.


With different versions of everything; anyone got this resolved?


Still not working and I’ve given up on it for a while. I’m thinking of trying PIAF and dumping AsteriskNOW